Приветствие

Логотип Password Safe

Сколько имён пользователей и паролей паролей вы используете? Независимо от того, будет вашим ответом «один» или «сотни», с помощью Password Safe вы легко создадите защищённый зашифрованный список паролей. Для доступа к ним вам необходимо запомнить лишь один мастер-пароль.

Обеспечение безопасности начинается с пользователя. Хранить пароли записанными на клочках бумаги или в записных книжках на столе небезопасно, да и любопытные глаза (машины или человека) могут подсмотреть их. Использование одного и того же пароля на всех компьютерах и веб-сайтах может привести к реализации кошмарного сценария, в котором кто-то, разгадав этот пароль, получает доступ ко всему, что у вас есть (компьютерам, электронной почте, финансам, рабочим файлам).

С помощью Password Safe вы сможете как управлять ранее созданными паролями, так и с лёгкостью создавать, хранить, упорядочивать, восстанавливать и использовать новые сложные пароли, удовлетворяющие заданным правилам сложности. Однажды сохранив имя пользователя и пароль, затем вы сможете найти их сделав лишь несколько щелчков мышью.

С помощью Password Safe вы можете упорядочить свои пароли по различным настраиваемым полям, например, по имени пользователя, категории, веб-сайту, или расположению. Для хранения паролей можно создать один список, зашифрованный с использованием мастер-пароля (зашифрованный контейнер), или же разбить их каким-либо образом на несколько групп (например, на домашние и рабочие) и использовать для них отдельные контейнеры с различными мастер-паролями. Благодаря интуитивно-понятному интерфейсу вы разберётесь в программе за несколько минут.


О Password Safe

Password Safe и использованный в нём алгоритм шифрования Twofish разработаны и опубликованы Брюсом Шнайером (Bruce Schneier) и Counterpane Labs.

Сейчас Password Safe является программным обеспечением с открытым исходным кодом и размещается на sourceforge.net. Последние обновления, документация и новости расположены на сайте http://pwsafe.org.

Password Safe находится в свободном доступе и распространяется с учётом ограничений установленных Open Source Initiative (OSI) «Artistic License 2.0». Копия лицензии (на английском языке) включена в поставку Password Safe и находится в файле LICENSE.

Twofish — быстрый и свободный алгоритм шифрования, являющийся альтернативой AES, DES и IDEA. Описание алгоритма Twofish, включая сравнение скоростных характеристик и перечень продуктов, его использующих, доступны по адресу http://www.schneier.com/twofish.html.

Файлы Readme.txt, Changelog.txt, и ReleaseNotes.txt (ReleaseNotes.html) содержат перечень последних изменений, а также информацию об исправленных ошибках и дополнениях в документации.

Все другие торговые марки и названия продуктов являются товарными знаками соответствующих компаний. Техническая поддержка со стороны этих компаний отсутствует и не подразумевается.


Password Safe и YubiKey

YubiKey это инновационное устройство аутентификации разработанное и продаваемое корпорацией Yubico. Для пользователя YubiKey на небольшую флешку с кнопкой на одной из сторон. Для Password Safe он выступает как маркер аутентификации (токен), добавляющий привязку к физическому устройству для защиты контейнера. YubiKey

Приобретение YubiKey

Очевидно, что для работы в таком режиме вам необходимо иметь YubiKey. Его можно приобрести в интернет-магазине Yubico. Для работы Password Safe требуется устройство с версией прошивки 2.2 и выше.

Настройка YubiKey

Перед началом работы YubiKey должен быть настроен для взаимодействия с Password Safe. Требуемые действия выполняются в пункте меню «Управление→YubiKey...» (описание доступно в разделе Управление).
Для хранения своих данных Password Safe использует слот № 2, оставляя 1-й слот свободным для использования в других приложениях.

Использование YubiKey

После того, как вы настроили YubiKey, его можно использовать вместе с мастер-паролем для защиты контейнера Password Safe (описание приведено в разделе Создание нового контейнера).


Создание и открытие нового контейнера

Password Safe позволяет хранить все пароли в одном или нескольких контейнерах (например, один для рабочих записей, другой — для личных данных). Контейнеры являются независимыми и, если версии Password Safe совпадают, могут свободно перемещаться и использоваться на различных машинах. Для шифрования контейнеров используется ключ, полученный на основе мастер-пароля (сам мастер-пароль не содержится в контейнере ни в каком виде).

Если вы используете Password Safe впервые, нажмите на кнопку «Новый...». Вам будет предложено указать каталог и имя файла для нового контейнера. Затем нужно ввести мастер-пароль, который будет использован для шифрования контейнера.

Перед тем как начать работу

Password Safe прилагает все усилия для того, чтобы корректно сохранить информацию о ваших паролях. Однако, Password Safe не может предотвратить повреждение или потерю вашего жёсткого диска, ноутбука или персонального компьютера. Поэтому, рекомендуется регулярно создавать резервные копии контейнера с паролями на другом носителе или компьютере. Это может быть сделано вручную или с использованием «облачных сервисов» (например, DropBox, SugarSync или JungleDisk).

Кроме того, может возникнуть необходимость в предоставлении доступа к сохранённым паролям родственникам или коллегам. Password Safe не содержит «чёрного хода» или «пароля для восстановления». Поэтому, при наступлении такой ситуации, вам придётся самостоятельно обеспечить доступ доверенным лицам к мастер-паролю. В зависимости от ситуации, вы можете хранить пароль в запечатанном конверте в ячейке банка или, использовать более сложные методы, например, разделение пароля на несколько частей и предоставление частей для хранения различным людям.

Создание нового контейнера

Контейнер можно создать двумя способами. Щёлкнув по кнопке Новый... в диалоге Пароль для контейнера, выводимом при запуске программы, или через меню Файл → Создать..., если Password Safe уже открыт. В любом из этих случаев будет выведен диалог Установка пароля для контейнера.

Примечание. По умолчанию Password Safe отображает последний использованный контейнер и запрашивает для него пароль. Если вы используете несколько контейнеров, можно выбрать другой контейнер из выпадающего списка. Также можно ввести путь к файлу контейнера или выбрать его, нажав на кнопку «...». Если какой-либо контейнер уже открыт, можно открыть другой, нажав Открыть... в меню Файл.

Запрос при старте

Запрос нового пароля для контейнера

Использование YubiKey с Password Safe

Password Safe может использовать устройство YubiKey для обеспечения «двуфакторной аутентификации», то есть для того, чтобы ваш контейнер был защищён с помощью того, что вы знаете (мастер-пароль) и того, чем вы владеете (устройство YubiKey). Если у вас нет YubiKey, соответствующие кнопки не будут отображены в Password Safe, и вы можете пропустить описание их использования.

Если YubiKey подключён к ПК, будут видны кнопка «YubiKey» и текстовое поле с описанием (см. картинку выше). В этом случае YubiKey может быть использован для доступа к контейнеру Password Safe вместо мастер-пароля или же в дополнение к нему. Для большей безопасности мы рекомендуем, чтобы одновременно использовались оба способа: YubiKey и мастер пароль.

Установка мастера-пароля и YubiKey

Для использования настроенного YubiKey:
  1. Подключите YubiKey к USB-порту ПК, если это ещё не сделано. В окне «Установка пароля для контейнера» станет активной кнопка YubiKey и в поле справа появится текст «Нажмите на кнопку и коснитесь YubiKey».
  2. Установите мастер-пароль.
    1. Если для защиты контейнера вы желаете одновременно использовать YubiKey и мастер-пароль, («двуфакторная аутентификация»), тогда сначала введите пароль в поля «Пароль» и «Подтверждение», а затем щёлкните на кнопке с надписью YubiKey.
    2. Если для защиты вы желаете использовать только YubiKey, тогда оставьте поля «Пароль» и «Подтверждение» пустыми, и щёлкните на кнопке с надписью YubiKey.
    3. Конечно, вы также можете использовать только мастер-пароль. В этом случае просто введите пароль в поля «Пароль» и «Подтверждение» и нажмите кнопку OK.
  3. Нажмите кнопку с надписью YubiKey. Текст «Нажмите на кнопку и коснитесь YubiKey» изменится на индикатор, показывающий оставшееся время, в течение которого вы должны активировать YubiKey прикоснувшись к «кнопке» на устройстве (мигающий зелёный огонёк). Если привязка не будет выполнена в течение отведённого времени (около 15-ти секунд), будет выведено сообщение об ошибке. После этого вы можете повторить попытку попытку или отменить действие.
  4. Контейнер Password Safe будет создан сразу после активации ключа YubiKey.

Открытие контейнера с помощью YubiKey

Чтобы открыть контейнер Password Safe, защищённый YubiKey:
  1. Убедитесь, что в поле «Открыть контейнер» указан требуемый файл. Если это не так, нажмите на кнопку «...» и выберите файл.
  2. Если для защиты контейнера используются YubiKey и мастер-пароль, тогда сначала введите пароль в поле «Пароль», а затем щёлкните на кнопке с надписью YubiKey. Если для защиты вы желаете использовать только YubiKey, тогда оставьте поле «Пароль» пустым, и щёлкните на кнопке с надписью YubiKey.
  3. После нажатия на кнопку с надписью YubiKey, текст «Нажмите на кнопку и коснитесь YubiKey» изменится на индикатор, показывающий оставшееся время, в течение которого вы должны активировать YubiKey прикоснувшись к «кнопке» на устройстве (мигающий зелёный огонёк). Если привязка не будет выполнена в течение отведённого времени (около 15-ти секунд), будет выведено сообщение об ошибке. После этого вы можете повторить попытку попытку или отменить действие.
  4. Контейнер Password Safe будет открыт сразу после активации ключа YubiKey.

Экранная клавиатура

Внутри мастер-пароля вы можете использовать символы иностранных алфавитов, например, ä, ö для немецкой раскладки. Чтобы ввести такие символы, требуется соответствующая раскладка клавиатуры. Дополнительные раскладки также доступны через экранную клавиатуру. Она может быть использована для всех иностранных алфавитов. Для отображения экранной клавиатуры нужно нажать кнопку Символ экранной клавиатуры . Указанный метод может использоваться для ввода символов, которые недоступны при использовании системной раскладки. Таким образом можно ввести любой желаемый мастер-пароль или его часть.

Ввод пароля с помощью экранной клавиатуры


Использование сохранённых паролей

Password Safe предлагает несколько способов использования сохранённых имён пользователей и паролей. Чаще всего требуется копирование имени пользователя и пароля в буфер обмена и вставка их в поле ввода. В Password Safe есть функция автонабора, которая автоматизирует ввод имени пользователя и пароля в web-формы.

  1. Откройте Password Safe.
  2. Выберите имя пользователя/пароль, которые собираетесь использовать.
    Имя пользователя:
  • Щёлкните на панели инструментов по значку, соответствующему имени пользователя
    или
  • Щёлкните на элементе правой кнопкой мыши и в контекстном меню выберите Копировать имя пользователя в буфер обмена
    или
  • Нажмите Ctrl+U
    и затем вставьте имя пользователя из буфера обмена в нужное поле.
    Пароль:
  • Щёлкните на панели инструментов по значку, соответствующему паролю
    или
  • Щёлкните на элементе правой кнопкой мыши и в контекстном меню выберите Копировать пароль в буфер обмена
    или
  • Щёлкните дважды по выбранному элементу
    или
  • Нажмите Ctrl+C
    и затем вставьте пароль из буфера обмена в нужное поле.

Примечание. Имя пользователя и пароль также могут быть скопированы в буфер обмена через меню Изменить.


Поиск

Поиск указанного текста

Password Safe позволяет производить поиск элементов по заданному тексту. Это удобно, если вы не помните имя элемента, но знаете, что в нём содержится, например, элемент, содержащий в заметках имя «Маша».

Для поиска в открытом контейнере нажмите Ctrl+F (или «Изменить»→«Поиск»). Над строкой состояния появится панель поиска, похожая на ту, что изображена на рисунке.

Для начала поиска достаточно ввести нужный текст и нажать Enter или щёлкнуть по значку с лупой, расположенному справа от поля ввода. Количество найденных элементов (если такие есть) будет отображено в правой части панели, а первый подходящий элемент будет выделен и получит фокус. Для перехода к следующему найденному элементу нажмите Enter (или кнопку с лупой). После того, как все элементы будут пройдены, Password Safe перейдёт на первый найденный элемент.

Нажатие на клавишу F3 повторяет поиск. Для перемещения по найденным элементам просто нажимайте F3. При одновременном нажатии Shift и F3, выделение перейдёт на предыдущий найденный элемент контейнера. То же самое произойдёт, если нажать на кнопку с лупой удерживая клавишу Shift.

  • Для закрытия панели поиска нужно нажать на «x» слева от поля ввода.
  • По умолчанию поиск является регистронезависимым. Для переключения между регистрозависимым и регистронезависимым поиском щёлкните по кнопке с надписью «AA». При переключении на регистрозависимый поиск надпись изменяется на «Aa». (При использовании «современных» значков на кнопке изображены буквы «TT».)
  • Если требуется указать дополнительные параметры поиска (ограничить подмножество элементов или выбрать отдельные поля элементов), щёлкните по значку «...».
  • Для создания отчёта о найденных элементах щёлкните по значку создание отчёта о поиске.
  • Для очистки поля с искомым текстом нажмите кнопку, на которой изображён ластик.


Переход на новые версии Password Safe

При изменении старшей цифры в версии программы изменяется формат контейнера. Это делается для того, чтобы повысить безопасность и/или реализовать работу новых функции. Для того, чтобы сделать переход на новую версию как можно более простым и прозрачным приложено много усилий.

  • Версия Password Safe 1.x поддерживает чтение контейнеров, созданных в версии 1.x.
  • Версия Password Safe 2.x может читать контейнеры, созданные в версиях 2.x и 1.x.
  • Версия Password Safe 3.x может читать контейнеры всех предыдущих форматов.

Открытие контейнера, созданного с помощью предыдущих версий Password Safe, происходит таким же образом, как открытие контейнера для текущей версии. Элементы будут отображаться как обычно, за исключением того, что некоторые поля могут быть не заполнены, так как они отсутствовали в ранних версиях (например, дата создания элемента).

При сохранении такой контейнер будет обновлён до текущего формата, и перестанет распознаваться предыдущими версиями Password Safe.

Создание контейнеров в формате предыдущих версий

Вы можете создать копии контейнера, читаемые в предыдущих версиях Password Safe используя экспорт в требуемый формат (Файл→Экспортировать в, а затем Формат v1.x или Формат v2.x). Обратите внимание, что в этих контейнерах не будет содержаться информации, добавленной в новых версиях. Например, контейнер второй версии не будет содержать данных о времени изменения элемента.


Несколько слов о мастер-пароле

Выбор надёжного мастер-пароля для контейнера Password Safe это один из важнейших шагов в обеспечении безопасности данных. Контейнер содержит всю введённую в Password Safe информацию (имена, пароли, заметки, ...). Выбор в качестве пароля имени супруга, даты рождения или любой другой простой для подбора комбинации делает хранящиеся там данные уязвимыми. Очень важно, чтобы вы выбрали сложный для подбора мастер-пароль, который легко сможете запомнить.

Password Safe имеет встроенные средства проверки сложности мастер-пароля. Мастер-пароль (как и любой другой) должен состоять из букв разного регистра, содержать хотя бы одну цифру или специальный символ (например, один из тех, что расположены над цифрами на клавиатуре). Если программа решит, что выбранный пароль является слабым, будет выдан запрос подтверждения. Вы можете подтвердить использование введённого «слабого» пароля, или ввести новый пароль.

Порядок изменения мастер-пароля описан в разделе Изменение мастер-пароля для контейнера.

Примечание. В Password Safe не существует механизма для восстановления потерянных (забытых) мастер-паролей.

Это осознанное решение разработчиков, так как любой механизм восстановления потерянных паролей является брешью в системе защиты и может быть использован злоумышленниками.


Имена пользователей и пароли

Имена пользователей, пароли и группы: основные

Имена пользователей, пароли и группы, а также другие параметры настраиваются на четырёх вкладках:

  • Основные: все необходимые элементы, связанные с управлением паролями
  • Дополнительно: дополнительные характеристики, включая историю паролей
  • Дата и время: дата истечения пароля и статистика
  • Политика создания паролей: переопределяет для данного элемента «политику по умолчанию»

Большинство меток на вкладках «Основные» и «Дополнительно» являются функциональными. При щелчке на них значение соответствующего поля копируется в буфер обмена. После копирования в буфер метка моргнёт зелёным цветом. В настоящий момент следующие метки являются функциональными:

  • Основные
    • Группа
    • Заголовок
    • Имя пользователя
    • Пароль
    • Заметки
    • Ссылка
    • E-mail
  • Дополнительно
    • Автонабор
    • Выполнить команду

      • Примечание. Если при щелчке на метке «Автонабор» или «Выполнить команду» удерживать клавишу Ctrl, то при копировании в буфер обмена не будут подставлены значения переменных.

Вкладка «Основные»

На данной вкладке собраны самые важные элементы.

Редактирование/просмотр элемента

Ниже приведено описание полей, связанных с каждым элементом:

  • Группа: имя, используемое для группировки (систематизации) связанных элементов;
  • Заголовок: имя, характеризующее данный элемент;
  • Имя: имя пользователя;
  • Пароль: пароль;
  • Заметки: произвольные заметки для данного элемента;

Обязательными являются только поля заголовок и пароль.

Также можно заполнить следующие поля:

  • Ссылка: ссылка, связанная с данным элементом. Если поле заполнено, становится активной кнопка «Перейти». Если протокол не указан, считается, что это HTTP-ссылка (т. е. «www.foo.net» эквивалентно «http://www.foo.net»). Щелчок с клавишей Control (Ctrl+Щелчок) вызывает автонабор на открытой в браузере странице. Для получения дополнительной информации см. примечания.
  • E-Mail: адрес электронной почты, связанный с данным элементом. Данное поле предназначено для хранения E-Mail, связанного с сайтом, например, адреса техподдержки support@myvendor.com. Если сайт требует указания адреса электронно почты в качестве логина, удобнее сохранить его в поле «Имя пользователя».
    Если поле заполнено, становится активной кнопка «Отправить». Нажатие данной кнопки приводит к созданию нового письма через почтовый клиент по умолчанию. При этом в поле «Кому» заносится указанный здесь адрес. Для получения дополнительной информации см. примечания.
Особенности работы со ссылками:
  • По умолчанию для открытия веб-страниц Password Safe использует настроенный в системе браузер по умолчанию. В случае необходимости можно использовать альтернативный браузер, добавив к ссылке приставку «[alt]» (например, «[alt]http://www.foo.net»). Данный функционал может потребоваться, например, если в качестве браузера по умолчанию настроен Firefox, а связанный с элементом сайт лучше работает в Internet Explorer. Настройка параметров альтернативного браузера производится на вкладке Управление→Настройки→Разное.
  • Если указана приставка «{alt}», то ссылка передаётся браузеру без изменений (не добавляется «http://» для ссылок, в которых не указан протокол). Это может потребоваться, если в качестве альтернативного браузера указан SSH-клиент или другое приложение для удалённого доступа. Приставка «[ssh]» оказывает тот же эффект.
  • Если добавлена приставка «[autotype]», то после открытия ссылки производится автонабор по заданным в соответствующем поле правилам.
Адрес электронной почты обрабатывается согласно правилам, указанным в RFC 2368.
  • Поле может содержать один или несколько корректных адресов, разделённых символом «;». Специальные символы необходимо кодировать. Так, вместо символа «пробел» следует указывать %20.
  • После адреса может идти одна или несколько пар имя=значение. Перед первой парой должен стоять знак «?», последующие пары отделяются символом «&». В качестве имени в паре может быть указано одно из следующих значений:
    • subject — значение, указанное после знака «=», будет помещено в тему письма.
    • body — значение, указанное после знака «=», будет помещено в тело письма.
    • CC — значение, указанное после знака «=», будет помещено в поле «CC» (копия) сообщения.
    • BCC — значение, указанное после знака «=», будет помещено в поле «BCC» (скрытая копия) сообщения.

    Пример: user@example.com?subject=Заголовок&body=Привет

Создание нового элемента

  1. Откройте контейнер, в который требуется добавить новый элемент.
  2. В меню Изменить выберите Добавить элемент.
  3. Заполните необходимые поля в диалоге Редактирования/просмотра элемента.
Примечание. Если при создании нового элемента была выбрана группа, её имя автоматически помещается в поле «Группа» диалога Редактирование/просмотр элемента. Если в поле «Группа» указать новое имя, будет создана группа с таким же именем.

Создание и редактирование паролей

Вы можете ввести пароль вручную, или создать его в соответствии с установленной Политикой создания паролей. Для того, чтобы Password Safe создал новый пароль, нажмите кнопку Создать в диалоге Редактирование/просмотр элемента. Если созданный пароль вам не подходит, нажмите кнопку ещё раз или измените пароль вручную.

Примечание. Если вы используете системы «единого входа», которые позволяют использовать один и тот же пароль для различных машин/серверов/приложений, то можно настроить несколько элементов Password Safe таким образом, чтобы изменение пароля в одном из них автоматически отражалось в остальных. Использование псевдонимов подробно описано в соответствующем разделе.

Редактирование существующих элементов

  1. Выберите элемент для редактирования.
  2. В меню Изменить нажмите Редактирование/просмотр элемента.
Примечание. По умолчанию пароль скрыт. Для просмотра связанного с этим элементом пароля нажмите кнопку Показать.

Добавление новой группы

  1. В меню Изменить выберите пункт Добавить группу.
  2. Введите имя новой группы.

Редактирование имени группы

  • Щёлкните правой кнопкой мыши на имени группы и в контекстном меню выберите пункт Переименовать группу.
Примечания:
  1. Группы могут быть вложенными.
  2. Группы не существуют как таковые. Группа существует только если внутри неё или её подгруппы есть элементы. Таким образом, если сохранить контейнер сразу после создания группы (до того, как в группу или её подгруппу будут добавлены элементы), группа исчезнет. Для того, чтобы новая группа гарантированно сохранилась, можно создать новый элемент и набрать требуемое имя в поле «Группа» (вложенные группы разделяются точкой «.»).

Защищённые элементы

Поля в защищённых элементах не могут быть изменены. Чтобы снять защиту с выберите в контекстном меню элемента (или в меню «Изменить») «Снять защиту». У защищённых элементов внизу вкладки присутствует соответствующая запись.

Редактирование/просмотр элемента


Имена пользователей и пароли

Имена пользователей, пароли и группы: дополнительно

Имена пользователей, пароли и группы, а также другие параметры настраиваются на четырёх вкладках:

  • Основные: все необходимые элементы, связанные с управлением паролями
  • Дополнительно: дополнительные характеристики, включая историю паролей
  • Дата и время: дата истечения пароля и статистика
  • Политика создания паролей: переопределяет для данного элемента «политику по умолчанию»

Вкладка «Дополнительно»

  • Автонабор: если поле не пусто, его содержимое заменяет на параметры автонабора, установленные по умолчанию (значение по умолчанию указано сверху и берётся из настроек Password Safe для текущего контейнера, задаваемых на вкладке Управление→Настройки→Разное). Для получения дополнительной информации см. Автонабор.

  • Выполнить: данное поле используется для указания команды/программы, выполняемой при выборе пункта «Выполнить команду» (в меню «Изменить» или контекстном меню) или по горячей клавише Ctrl+R. Password Safe может передать в качестве аргументов имя пользователя, пароль и содержимое других полей, описанных здесь.

  • Действие по двойному клику и действие по Shift+двойной клик: задаёт действие, которое Password Safe выполнит при двойном щелчке на элементе или при двойном щелчке на элементе с нажато клавишей Shift. Действиями по умолчанию являются копирование пароля в буфер обмена для двойного клика и копирование имени пользователя в буфер обмена для Shift+двойной клик. В выпадающих списках значение по умолчанию помечено фразой «(по умолчанию)». Изменить значение по умолчанию можно на вкладке Управление→Настройки→Разное.

  • История паролей: Password Safe может сохранять несколько предыдущих значений пароля. Настройку можно задать при создании или редактировании элемента. В списке отображаются предыдущие пароли для указанного элемента. Количество сохраняемых предыдущих паролей может быть изменено позже. Для получения дополнительной информации см. История паролей.

  • Комбинация клавиш: элементам контейнера можно назначить комбинации клавиш («горячие клавиши»), которые позволят выбирать их сразу после нажатия такое комбинации, независимо от текущего положения в контейнере.

    Особенности работы с горячими клавишами:
    • Комбинации клавиш для элементов хранятся как часть данных элемента внутри контейнера. Но, помимо этого, Password Safe позволяет задавать горячие клавиши для пунктов меню. Область действия горячих клавиш для пунктов меню распространяется на все контейнеры, открываемые на данном ПК. Значения по умолчанию зависят от выбранного языка. Ручная настройка горячих клавиш для пунктов меню производится на вкладке Управление→Настройки→Комбинации клавиш.
    • По этой причине, если вы выберете для элемента ту же комбинацию клавиш, что уже назначена для пункта меню, будет выведено предупреждение. Это не приведёт к конфликта настроек, если позже вы измените язык локализации приложения или установите другую комбинацию для пункта меню. Аналогично, конфликта может не быть при назначении горячих клавиш, но он может произойти позже, если вы измените язык или комбинации клавиш для пунктов меню.
    • Т. к. использование комбинации клавиш связанных с элементами контейнера не изменяет сам контейнер (в отличие от комбинаций для пунктов меню, которые могу быть назначены на удаление элемента), горячим клавишам для элементов был дан более высокий приоритет в случае конфликта.
    • Комбинация клавиш для элемента должна содержать хотя бы один из модификаторов Alt и Ctrl (с или без Shift). Если ни Alt, ни Ctrl не присутствуют в комбинации, для получения уникальной комбинации проверяются все комбинации модификаторов Ctrl, Alt и Shift (в порядке Alt; Alt+Shift; Ctrl; Ctrl+Shift, Alt+Ctrl; Alt+Ctrl+Shift). Например, комбинация «Shift + 6» может быть заменена на «Alt + Shift + 6». Но, «Ctrl + 6» не будет изменяться автоматически.
    • Комбинация клавиш отвязывается от элемента, если она уже назначена другому элементу и
      • Элемент был импортирован (из простого текстового файла или XML-файла). Примечание. Об этом также будет сообщено в журнале импорта.
      • Элементы был добавлен при слиянии контейнеров. Примечание. Об этом также будет сообщено в журнале слияния.
      • Элемент был «перетянут» из другого контейнера. При перетаскивании внутри текущего контейнера этого не произойдёт.
      • Элементы был скопирован из диалога результатов сравнения контейнеров.
      • Элементы был создан посредством дублирования группы или элемента.

Список используемых в Password Safe комбинаций клавиш для элементов отображается под списком горячих клавиш для пунктов меню на вкладке Управление→Настройки→Комбинации клавиш. Для просмотра/редактирования связанного элемента щёлкните дважды на назначенной комбинации. Также вы можете включить отображение столбца с комбинации клавиш в режиме Простого списка и/или создать фильтр, отображающий только элементы с назначенными горячими клавишами.


Имена пользователей и пароли

Имена пользователей, пароли и группы: дата и время

Имена пользователей, пароли и группы, а также другие параметры настраиваются на четырёх вкладках:

  • Основные: все необходимые элементы, связанные с управлением паролями
  • Дополнительно: дополнительные характеристики, включая историю паролей
  • Дата и время: дата истечения и статистика
  • Политика создания паролей: переопределяет для данного элемента «политику по умолчанию»

Вкладка «Дата и время»

Редактирование/просмотр: дата и время
  • Пароль истекает: для указания даты истечения пароля нажмите кнопку «Задать» и введите желаемую дату в абсолютном («22 декабря 2010») или относительном («через 30 дней») формате. Незадолго до наступления указанной даты Password Safe при запуске выведет уведомление и пометит элемент другим цветом.
    В случае выбора «Через N дней» можно поставить флажок «Повторять». Тогда при смене пароля новая дата истечения будет рассчитана автоматически. Пусть элемент был создан 1 января, и для него установлен срок действия в пять дней с повтором. Напоминания об истечении срока будут выводиться начиная с 6 января. Если изменить пароль 7 января, то он будет действовать до 12 января (в течение пяти дней со дня смены).
  • Чтобы прекратить использование срока действия пароля выберите «Нет».
  • Статистика: поля в этой группе содержат информацию о времени создания, последнего доступа и пр.

Примечание. Password Safe только предупреждает об истечении срока действия пароля. По окончании срока действия пользователь должен самостоятельно изменить пароль. Пункт меню Просмотр→Показать элементы с заданными датами истечения пароля применяет внутренний фильтр, отображающий только те элементы, у которых задана дата истечения пароля (независимо от того, наступила она или нет). При повторном выборе этого пункта фильтр будет снят, и отобразятся все элементы.

 Фильтр для истекающих паролей


Имена пользователей и пароли

Имена пользователей, пароли и группы: политика создания паролей

Имена пользователей, пароли и группы, а также другие параметры настраиваются на четырёх вкладках:

  • Основные: все необходимые элементы, связанные с управлением паролями
  • Дополнительно: дополнительные характеристики, включая историю паролей
  • Дата и время: дата истечения пароля и статистика
  • Политика создания паролей: переопределяет для данного элемента «политику по умолчанию»

Вкладка «Политика создания паролей»

Редактирование/просмотр: политика создания паролей

Если для выбранного элемента вы не желаете использовать «политику по умолчанию» (см. Настройка политики создания паролей), нужно выбрать на данной вкладке значение «Переопределить политику» и указать необходимые параметры в соответствующих полях. Также можно указать свой набор символов для создания пароля. Для того, чтобы ваш набор символов использовался по умолчанию, укажите его на вкладке Управление→Настройки→Политика создания паролей.


Политика создания паролей

Политика создания паролей

Политика паролей описывает правила, используемые при создании паролей: буквы, их регистр, длина паролей и использование спецсимволов. В некоторых случаях требуется создавать пароли, содержащие только строчные буквы, в других требуется наличие прописных букв, цифр и спецсимволов, а также указание минимальной длины. В общем случае лучше всего использовать пароли максимально допустимой длины, состоящие из смеси символов различных наборов. На всякий случай проверяйте соответствие созданного пароля указанным требованиям.

Свой набор символов для создания пароля можно задать через меню Управление→Политики создания паролей.... Кроме того, каждый элемент может иметь свой набор символов для пароля, задаваемый в диалоге добавления/редактирования элемента. Примечание. Эти символы не используются при создании произносимых или удобочитаемых паролей.

Диалог Управление политиками создания паролей позволяет задавать глобальные правила создания паролей. Все настройки политик сохраняются в заголовке контейнера и поэтому привязаны к нему. Данная политика и пароль могут быть переопределены в диалоге редактирования/просмотра элемента.

Выбор правил создания паролей

Каждый флажок (например Цифры, Строчные буквы и т. д.) заставляет Password Safe включать указанные символы в создаваемый пароль. Созданный пароль будет иметь указанную длину (ни больше, ни меньше). Единственное исключение — настройка Только шестнадцатеричные цифры (0–9, a–f). Если флажок установлен, будут использованы только символы, представляющие шестнадцатеричные цифры. Установка данного флажка блокирует другие настройки политики.

Выбор Создавать произносимые пароли приведёт к тому, что Password Safe будет создавать бессмысленные, но произносимые на английском языке слова, например, «ingstria», «ringsony», и пр. Данная опция может быть удобна в случае, если требуется создать стойкий пароль, который легко запомнить без Password Safe. Указание данной настройки вместе с Цифры и/или Символы приведёт к замене некоторых букв сходными по написанию знаками («leet-эквивалентами»), например, «E» может быть заменено на «3», «S» на «5», и т. д.

Если поставлен флажок Символы, к алфавиту добавляются следующие символы: + - = _ @ # $ % ^ & ; : , . < > / ~ \ [ ] ( ) { } ? ! |. Если установлен флажок Только удобочитаемые символы, набор символов сокращается до + - = _ @ # $ % ^ & < > / ~ \ ?

При установленном флажке Только удобочитаемые символы набор букв сокращается до: a b c d e f g h i j k m n o p q r s t u v w x y z и A B C D E F G H J K L M N P Q R T U V W X Y, а набор цифр ограничивается 3 4 6 7 8 9.


История паролей

Password Safe может сохранять некоторое количество предыдущих паролей (и дату изменения) для данного элемента. Это позволяет показать соответствие политикам создания паролей (что может быть необходимым в некоторых случаях), а также вернуться к предыдущему паролю, если по какой-либо причине смена пароля не удалась. История изменения паролей доступна на вкладке «Дополнительно» диалога редактирования элемента.

История паролей

Здесь отображаются несколько предыдущих паролей, связанных с данным элементом. Допустимы следующие действия:

Хранить N предыдущих паролей

Если флажок установлен, для данного элемента будут сохраняться предыдущие пароли. Также указывается количество сохраняемых паролей.
Примечание. Снятие флажка не приводит к очистке истории. После этого Password Safe лишь перестаёт сохранять пароли при последующих изменениях.

Копирование пароля

Одинарный или двойной щелчок на строке списка приводит к копированию соответствующего пароля в буфер обмена.

Очистить

При нажатии на данную кнопку история паролей для этого элемента будет очищена.

Примечание. Фактически история паролей очищается только после нажатия на кнопку «OK». Если вы нажали кнопку «Очистить» по ошибке, нажмите «Отмена» для отклонения изменений.

Копировать все

При нажатии на данную кнопку вся история паролей будет скопирована в буфер обмена.


Изменение пароля для контейнера

Изменение мастер-пароля для контейнера

Для изменения мастер-пароля откройте контейнер, пароль которого требуется изменить. После этого в меню Управление выберите пункт Изменить пароль для контейнера. Будет отображён следующий диалог:

Диалог изменения пароля

Примечание. Если у вас нет YubiKey, соответствующие кнопки не будут отображены, и вы можете пропустить описание их использования.

Для изменения мастер-пароля откройте контейнер, пароль которого требуется изменить. После этого в меню Управление выберите пункт Изменить пароль для контейнера. Здесь необходимо ввести текущий мастер-пароль, а затем, новый пароль (вводится дважды, для подтверждения). Для ввода пароля можно использовать физическую или экранную клавиатуру.

Password Safe имеет встроенные средства проверки сложности мастер-пароля. Мастер-пароль (как и любой другой) должен состоять из букв разного регистра, содержать хотя бы одну цифру или специальный символ (например, один из тех, что расположены над цифрами на клавиатуре). Если программа решит, что выбранный пароль является слабым, будет выдан запрос подтверждения. Вы можете подтвердить использование введённого «слабого» пароля, или ввести новый пароль.

Для тех, кто использует YubiKey: в дополнение к функции смены мастер-пароля, этот диалог позволяет добавить или убрать аутентификацию при помощи YubiKey, установить или убрать пароль, используемый вместе с YubiKey, или привязать к контейнеру другой ключ YubiKey. Ниже приведены инструкции по выполнению перечисленных действий.

Добавление аутентификации при помощи YubiKey

Чтобы изменения способа аутентификации при доступе к контейнеру Password Safe с мастер-пароля на YubiKey:
  1. Введите текущий мастер-пароль в поле «Старый пароль».
  2. Подключите YubiKey
  3. Если требуется, введите (и подтвердите) новый пароль в поля «Новый пароль» и «Подтверждение».
  4. Нажмите на кнопку с надписью YubiКey, расположенную рядом с полем Новый пароль и коснитесь кнопки на устройстве YubiKey.

Удаление аутентификации при помощи YubiKey

Для того, чтобы изменить параметры аутентификации при доступе к контейнеру на использование только мастер-пароля:
  1. Подключите YubiKey.
  2. Если для доступа к контейнеру также используется пароль, введите его в поле «Старый пароль».
  3. Нажмите на кнопку с надписью YubiКey, расположенную рядом с полем Старый пароль и коснитесь кнопки на устройстве YubiKey.
  4. Введите новый пароль и его подтверждение в соответствующие поля.
  5. Нажмите OK.

Добавление/удаление/изменение мастер-пароля

Password Safe может использовать YubiKey как единственны способ аутентификации, так и как дополнительны к обычному паролю. Для переключения между этими режимами:
  1. Подключите YubiKey.
  2. Если для доступа к контейнеру также используется пароль, введите его в поле «Старый пароль».
  3. Нажмите на кнопку с надписью YubiКey, расположенную рядом с полем Старый пароль и коснитесь кнопки на устройстве YubiKey.
  4. В полях «Новый пароль» и «Подтверждение» установите пустое значение, чтобы отключить проверку пароля, или новый пароля чтобы изменить или добавить проверку пароля.
  5. Нажмите на кнопку с надписью YubiКey, расположенную рядом с полем Новый пароль и коснитесь кнопки на устройстве YubiKey.

Изменение YubiKey

Для привязку другого YubiKey:

  1. Подключите старый YubiKey.
  2. Если для доступа к контейнеру также используется пароль, введите его в поле «Старый пароль».
  3. Нажмите на кнопку с надписью YubiКey, расположенную рядом с полем Старый пароль и коснитесь кнопки на устройстве YubiKey.
  4. Отключите старый YubiKey и подключите новый.
  5. Если требуется, введите (и подтвердите) новый пароль в поля «Новый пароль» и «Подтверждение».
  6. Нажмите на кнопку с надписью YubiКey, расположенную рядом с полем Новый пароль и коснитесь кнопки на устройстве YubiKey.

Примечания:
  • В Password Safe не существует механизма для восстановления потерянных (забытых) мастер-паролей.
    Это осознанное решение разработчиков, так как любой механизм восстановления потерянных паролей является брешью в системе защиты и может быть использован злоумышленниками.
  • Всегда выбирайте пароли, которые сложно угадать. Простой пароль, такой как «пароль» или ваше имя, легко подбирается и сводит на нет защиту, обеспечиваемую Password Safe.


Автонабор

Автонабор предназначен для ускорения и упрощения ввода имени пользователя и пароля. Нажатия одной кнопки достаточно, чтобы заполнить поля для ввода имени пользователя и пароля и произвести вход. По умолчанию используется следующая последовательность нажатий клавиш: имя пользователя, затем табуляция, пароль, ещё одна табуляция, и Enter (имя пользователя TAB пароль TAB ENTER). Данная схема подходит для большинства сайтов, требующих аутентификацию по имени пользователя и паролю.

Для сайтов или приложений, требующих ввода дополнительных данных, доступна тонкая настройка автонабора, описание которой приведено в разделе Настройка автонабора. Заметьте, что для автонабора последовательность по умолчанию может быть переопределена на вкладке Управление→Настройки→Разное. Например, это может потребоваться, если автонабор выполняется слишком быстро.

Также существует возможность вызова автонабора после запуска произвольных команд из поля Выполнить. Иногда это может быть очень удобным.

Использование автонабора

  1. Установите курсор в поле для ввода имени пользователя.
  2. Переключитесь на Password Safe или откройте его.
  3. Выберите элемент с необходимым именем пользователя и паролем.
  4. Для выполнения автонабора нажмите Ctrl+T (также можно щёлкнуть правой кнопкой мыши и выбрать в контекстном меню Автонабор или нажать соответствующую кнопку на панели инструментов).

Настройка автонабора

Для веб-сайтов или приложений, в которых за именем пользователя не идёт поле для ввода пароля и затем кнопка входа, можно изменить последовательность, заполнив поле «Автонабор» текстом, описывающим необходимое поведение.

  • \u заменяется на имя пользователя, соответствующее данному элементу.
  • \p заменяется на пароль, соответствующий данному элементу.
  • \g заменяется на группу, соответствующую данному элементу.
  • \i заменяется на заголовок данного элемента.
  • \l заменяется на соответствующую данному элементу ссылку (используется латинская буква l, а не единица).
  • \m заменяется на E-mail, соответствующий данному элементу.
  • \o заменяется содержимым (возможно многострочным) поля «заметки»:
    • символы конца строки «\n», «\r» или «\r\n» преобразуются в «\r» (возврат каретки);
    • для содержимого поля «заметки» не производится подстановка управляющих последовательностей («\u», «\p» и т. д.) кроме «\t», заменяемой на символ табуляции, и «\s», заменяемой на «Shift+Tab».
  • \oNNN заменяется n-й строкой поля «заметки»:
    • NNN может состоять из одной, двух или трёх цифр (например, \o5 для 5-й строки, \o45 для 45-й, и т. д.);
    • символы переноса строк не учитываются;
    • если NNN превышает количество строк в поле «заметки», то последовательность игнорируется.
    Примечание. Таким образом возможен автонабор для приложений, требующих во время аутентификации ввод второго пароля или произвольного текста.
  • \b заменяется клавишей «забой».
  • \t заменяется табуляцией и используется для перехода в следующее поле.
  • \s заменяется комбинацией «Shift+Tab» и используется для перехода в предыдущее поле.
  • \n заменяется клавишей ввода и используется для нажатия на кнопку.
  • \\ заменяется обратной косой чертой («\»).
  • \dNNN устанавливает задержку между вводом символов в NNN миллисекунд, вместо 10 мс, установленных по умолчанию. Изменение задержки оказывает влияние только на текущий и последующие символы. Например, «быстро\d500медленно» приведёт к тому, что «быстро» будет набрано со стандартной задержкой, а буквы 'м', 'е', 'д', 'л', 'е', 'н', 'н', 'о' с задержкой в полсекунды перед каждой буквой. Если требуется вставить однократную задержку, не влияющую на скорость ввода символов, используйте управляющие последовательности «\w» и «\W», описанные ниже.
  • \wNNN или \WNNN используется для указания задержки в NNN миллисекунд для «\w», и NNN секунд для «\W». Например, «как\w500было» набирает «как» (со стандартной межбуквенной задержкой или той, что была установлена с помощью «\d»), затем ждёт полсекунды и вводит «было» с той же межбуквенной задержкой, что и «как»). Аналогично, «как\W2сейчас» сделает задержку между словами в две секунды. Задержка может использоваться для тонкой настройки входа на некоторые веб-станицы.
  • Обратите внимание, что NNN в данном случае принимает не более 3-х цифр. Таким образом, «\w5000» выполнит задержку в полсекунды, после чего напечатает символ «0», что скорее всего отличается от того, что вы задумали (задержку в 5 секунд можно задать с помощью «\W5»).
  • \z использует «старый» механизм автонабора. В данном случае нелатинские символы могут вводиться некорректно, но также может улучшиться работа автонабора на некоторых проблемных веб-сайтах. Если вы заметили, что автонабор работает некорректно на каком-то из сайтов, попробуйте добавить данную ключевую последовательность в автонабор для этого элемента.
  • Все другие символы переносятся без изменений.

Пример. Если перед вводом имени и пароля нужно ввести номер счёта (12345), можно использовать следующую последовательность:

12345\t\u\t\p\t\n

Примечание. В случае возникновения проблем с автонабором попробуйте отключить блокировщики всплывающих окон (есть сообщения пользователей, указывающие на то, что блокирование всплывающих окон может привести к проблемам с автонабором).


Резервное копирование и восстановление контейнеров

Так как информация, хранящаяся в контейнере с паролями обычно является важной, Password Safe предоставляет несколько способов резервного копирования и восстановления контейнеров. В данном разделе описываются методы ручного создания резервных копий. Также в Password Safe можно настроить автоматическое создание резервных копий при сохранении контейнера. Такие резервные копии называются промежуточными и описываются здесь.

Создание резервной копии

Создание резервной копии текущего контейнера:

  1. Нажмите Создать резервную копию.
  2. Выберите расположение файла резервной копии.
  3. Нажмите Сохранить.

Примечание. Настоятельно рекомендуется делать резервные копии контейнеров как можно чаще. Этот поможет избежать потери списка паролей в случае системного сбоя или повреждения файлов. Для шифрования резервной копии используется тот же мастер-пароль, что и в текущем контейнере. В частности, на вкладке «Резервные копии» диалога «Управление→Настройки» можно указать необходимое количество хранимых резервных копий (мы рекомендуем оставлять от 3 до 5 копий) и способ именования (по счётчику или дате/времени).

Восстановление из резервной копии

Восстановление контейнера из резервного копии:

  1. Нажмите Восстановление из резервной копии.
  2. Перейдите в папку с резервной копией и выберите файл для восстановления.
  3. Нажмите Открыть. Будет запрошен пароль для контейнера.
  4. Введите пароль и нажмите OK.
Примечания:
  • Чтобы восстановленный контейнер сохранился со стандартным для Password Safe расширением «.psafe3», выберите в меню Файл пункт Сохранить или Сохранить как. Перед выходом из приложения будет предложено сохранить контейнер, если вы не сделали этого ранее.
  • Резервные копии создаются не только вручную, но и автоматически перед сохранением изменений в контейнере. Копия создаётся в том же каталоге, что и текущий контейнер, имеет то же имя и отличается лишь расширением («.ibak» вместо «.psafe3»). Дополнительную информацию об автоматическом резервном копировании можно найти здесь.


Вкладка «Резервные копии»

вкладка «Резервные копии»

Вкладка «Резервные копии» содержит параметры создания автоматических резервных копий.

Сохранять контейнер после вставки или редактирования

Если помечено, Password Safe будет без дополнительного запроса сохранять все изменения не дожидаясь того, что пользователь нажмёт Сохранить или Сохранить как.

Создавать копию (.ibak) перед сохранением

Если помечено, Password Safe будет копировать контейнер перед каждым сохранением. Имя файла, его расположение и количество сохраняемых копий указаны в следующих полях.

Имя для резервной копии

Имя для резервной копии состоит из начала (по умолчанию это имя файла контейнера без расширения «.psafe3»), и суффикса (может быть пустыми или содержать номер/дату/время резервного копирования). Здесь можно настроить именование резервных копий и их количество (Password Safe автоматически перезапишет старую копию при превышении указанного количества, если для создания суффикса используется «Автонумератор»).

Каталог для резервных копий

По умолчанию Password Safe создаёт резервные копии в том же каталоге, где находится открытый в настоящий момент контейнер. В этом поле можно указать другое расположение, например, отдельный каталог для резервных копий, сетевой диск, съёмный накопитель и т. п. Для корректной работы необходимо иметь права на запись в указанный каталог.


Аварийные резервные копии

При нормальном выходе из Password Safe, вам будет предложено сохранить изменения в контейнере. Однако, в некоторых случаях Password Safe не имеет возможности вывести запрос (например, при завершении сеанса Windows, выключении или перезагрузке компьютера возможность вывода предупреждения зависит от версии ОС и особенностей выключения компьютера).

В этом случае Password Safe попытается создать «Аварийную резервную копию» (файл с расширением «fbak»). Файл создаётся в том же каталоге, где находится текущий открытый контейнер. В этом случае сам контейнер и «обычные» резервные копии не изменяются.

При следующем открытии исходного контейнера Password Safe проверит наличие аварийных резервных копий и, в случае обнаружения, выведет похожий на приведённый ниже диалог:

Диалог с аварийными резервными копиями

В первом столбце указывается имя контейнера, в остальных — основная информация о контейнере (та же, что отображается при открытии пункта меню «Файл»→«Свойства»). Затем идёт список доступных аварийных резервных копий. Свойства контейнера отображаются в том случае, если к нему подходит введённый для текущего контейнера пароль. В случае, если пароль не подходит к этим контейнерам, в столбце «Пароль» отображается «Нет» и столбцы со свойствами не заполняются.

Можно выбрать одно из следующих действий:

  • Продолжить

    При нажатии данной кнопки Password Safe игнорирует наличие аварийных резервных копий и продолжает работу с выбранным контейнером.

  • Выбор

    Вместо текущего контейнера будет открыта выбранная аварийная резервная копия.

  • Удалить

    Выбранная аварийная резервная копия будет удалена. Файл перемещается в «Корзину», если ОС Windows поддерживает удаление в «Корзину» на данном диске (например, на локальных дисках). Иначе, файл будет удалён навсегда.

  • Выход

    Если данный контейнер был открыт при запуске Password Safe, программа будет закрыта. В противном случае, открытие нового контейнера будет отменено, а предыдущий контейнер останется открытым.

  • Помощь

    Будет открыт данный раздел справки.

Предложения:

  • Если вы затрудняетесь в выборе, нажмите кнопку «Продолжить» и используйте пункт меню «Файл»→«Сравнить» для определения различий между текущим контейнером и аварийной резервной копией.
  • Если Вы открыли аварийную резервную копию, и решили, что эту версию нужно оставить, сохраните данный файл как обычный контейнер, используя пункт меню «Файл»→«Сохранить как». Возможно, перед этим стоит переименовать исходный контейнер, или сохранить аварийную резервную копию под другим именем.
  • После того, как вы определили актуальный контейнер (оставили оригинальный или сохранили под другим именем аварийную резервную копию), нужно удалить оставшиеся фалы аварийных резервный копий, чтобы Password Safe не предупреждал об их существовании при последующих запусках. Примечание. При удалении файлов из этого диалога они перемещаются в корзину, если диск и ОС поддерживают данный функционал.

Примечание. Ни одно приложение не может сохранить данные при выключении питания компьютера во время работы или при фатальном сбое в компонентах ПК. Поэтому необходимо регулярно делать резервные копии важных данных на другие носители. Это могут быть Flash-диски, съёмные жёсткие диски, сетевые ресурсы, CD(DVD)-диски и прочие устройства, предназначенные для хранения данных. Резервные копии следует хранить в безопасном месте.


Импорт элементов

Password Safe позволяет импортировать данные о паролях из файлов других форматов. Данные файлы могут быть сформированы другими приложениями, экспортированы из таблиц, или даже составлены вручную в текстовом редакторе.

Password Safe поддерживает следующие форматы:

  • Простой текст
  • XML
  • TXT- и CSV-файлы KeePass V1
  • KeePass V2 через CSV-файлы KeePass V1
  • XML-файлы KeePass V1 и V2

По окончании операции импорта Password Safe создаёт отчёт, содержащий информацию о выполненной работе и возникших проблемах (если такие были). Содержимое отчёта может быть скопировано в буфер обмена или сохранено на диск в том же каталоге, где находится контейнер. Отчёт можно посмотреть позже с помощью меню «Просмотр»→«Отчёты». Отчёт имеет фиксированное имя, зависящее от его типа. При повторении действия и сохранении отчёта на диск, предыдущий отчёт для этого действия перезаписывается. Примечание. Отчёт может содержать важные данные, поэтому возможность сохранения на диск следует использовать с осторожностью.

Примечание. Чтобы импортировать элементы из другого контейнера Password Safe, запустите ещё одну копию Password Safe (должен быть разрешён запуск нескольких экземпляров на вкладке Управление→Настройки→Система) и откройте нужный контейнер. Затем перетяните из него необходимые элементы или группы в первый контейнер.

Текстовый формат

Импортируемые текстовые файлы содержат одну или несколько записей о паролях. Поля внутри элемента разделяются специальным символом. Информация об элементе может быть записана в одну или несколько строк. Описание формата импорта из текстового файла находится в разделе Формат текстового экспорта и импорта.

Настройки импорта из простого текста

Разделитель полей используется для выделения полей в текстовых строках. Также можно указать имя группы, в которую будут помещены все импортированные элементы.

Настройки импорта из простого текста

  1. Файл→Импортировать из
  2. Выберите Простой текст.
  3. Укажите параметры импорта из данного файла.
  4. Если при экспорте заметок был использован разделитель строк, укажите его, чтобы при импорте он был заменён на перенос строки.
  5. Нажмите OK.
  6. Выберите текстовый файл для импорта.
  7. По окончанию процесса импорта будет выведен диалог с информацией о количестве ошибок и успешно импортированных элементов.
Внимание! если элемент использует «именованную политику», которая отсутствует в текущем контейнере, то импортированному элементу будет назначена «политика по умолчанию».
Внимание! Первая строка импортируемого файла должна содержать список имён столбцов, разделённых табуляцией. Например: «Group/Title Username Password URL». Эта строка создаётся автоматически при экспорте в текст. Для файлов, созданных вручную (или с помощью других утилит), её нужно заполнить или отредактировать в соответствии с форматом.

XML

XML (eXtensible Markup Language) — распространённый формат для передачи данных между приложениями. Password Safe может импортировать XML-файлы, соответствующие схеме pwsafe.xsd, распространяемой вместе с Password Safe.

При импорте из XML-файла в пустой контейнер, в него также будут импортированы настройки контейнера. Если в контейнере уже есть элементы, поля с настройками игнорируются.

Однако, если XML-файл содержит именованные политики создания паролей, они будут импортированы независимо от того, есть ли в контейнере элементы. При этом, если в контейнере уже присутствует политика с таким же именем, она не будет замещена политикой из XML-файла.

Если импортируемый элемент использует именованную политику, которой нет в текущем контейнере и XML-файле, то ему будет назначена «политика по умолчанию».

Изменения в формате представления даты/времени в XML-файле

До версии 3.26 для экспорта использовался свой формат:

  <name>
    <date>гггг-ММ-дд</date>
    <time>чч:мм:сс</time>
  </name>

Где«name» — любое из имён полей, содержащих дату/время («ctime», «atime», «xtime», «pmtime», «rmtime», «changed»).

Начиная с версии 3.26 экспорт производится в соответствии со стандартом представления даты/времени, определённыым W3C. Версии 3.26 и 3.27 могли импортировать данные в любом из этих представлений, но с версии 3.27 поддерживается только формат из стандарта W3C.

Формат полей с датой/временем согласно стандарту W3C имеет следующее представление:

  <namex>гггг-ММ-ддTчч:мм:сс</namex>

Для того, чтобы можно было отличить теги, записанные в «старом» стиле от «новых», к их именам был добавлен суффикс «x» («ctimex», «atimex», «xtimex», «pmtimex», «rmtimex», «changedx»).

Для импорта файлов, содержащих дату/время в «старом» стиле, вам необходимо вручную преобразовать содержимое этих полей к представлению по стандарту W3C.

TXT- и CSV-файлы KeePass V1

Рекомендуемый способ импорта контейнеров KeePass V1 через XML-файл описан ниже.

Текстовый файл

Поддерживается импорт TXT-файлов KeePass V1 (проверено на файлах созданных KeePass V1.19b).

Перечисленные поля преобразуются в соответствующие поля Password Safe.

Каждый элемент начинается со строки заключённой в квадратные скобки («[»,«]»). Текст из этой строки считается заголовком элемента.

Каждое поле начинается с новой строки. Его содержание определяется по заголовку , указанному в начале строки.

  • «Group» — группа элемента.
  • «Group Tree» — перечень родительских групп до корня.
  • «User Name» — имя пользователя.
  • «Password» — пароль.
  • «URL» — ссылка.
  • «Notes» — заметки.
  • «UUID» — уникальный идентификатор элемента.
  • «Creation Time» — время создания элемента.
  • «Last Access» — время последнего доступа к элементу.
  • «Last Modification» — время изменения пароля и время последнего изменения.
  • «Expires» — дата истечения пароля.

Следующие поля игнорируются:

  • «Icon»
  • «Attachment Description»
  • «Attachment» — не экспортируйте данное поле, т. к. это приводит значительному увеличению размера файла.

Обратите внимание, что в Password Safe значение даты и времени должны быть не позднее 19 января 2038 г. Более поздние даты считаются некорректными, и соответствующие поля не заполняются.

Обратите внимание, что при экспорте из KeePass необходимо поставить флажок Encode/replace newline characters by '\n', иначе операция импорта может завершиться с ошибкой или привести к неожиданным результатам.

CSV-файл

Поддерживается импорт CSV-файлов KeePass V1 (проверено на файлах созданных KeePass V1.19b).

Перечисленные поля преобразуются в соответствующие поля Password Safe.

  • «Password Groups» — группа элемента.
  • «Group Tree» — перечень родительских групп до корня.
  • «Account» — заголовок элемента.
  • «Login Name» — имя пользователя.
  • «Password» — пароль.
  • «Web Site» — ссылка.
  • «Comments» — заметки.
  • «UUID» — уникальный идентификатор элемента.
  • «Creation Time» — время создания элемента.
  • «Last Access» — время последнего доступа к элементу.
  • «Last Modification» — время изменения пароля и время последнего изменения.
  • «Expires» — дата истечения пароля.

Следующие поля игнорируются:

  • «Icon»
  • «Attachment Description»
  • «Attachment» — не экспортируйте данное поле, т. к. это приводит значительному увеличению размера файла.

Обратите внимание, что в Password Safe значение даты и времени должны быть не позднее 19 января 2038 г. Более поздние даты считаются некорректными, и соответствующие поля не заполняются.

Обратите внимание, что при экспорте из KeePass необходимо поставить флажок Encode/replace newline characters by '\n', иначе операция импорта может завершиться с ошибкой или привести к неожиданным результатам.

KeePass V2 через CSV-файлы KeePass V1

Рекомендуемый способ импорта контейнеров KeePass V2 через XML-файл описан ниже.

Password Safe не может напрямую импортировать файлы, созданные KeePass V2 (даже файлы экспорта в KeePass V1 CSV из KeePass V2). Но существует возможность экспортировать контейнер KeePass V2 в формат KeePass V1. После этого можно экспортировать данные в TXT- или CSV-формат и импортировать их как описано выше.

XML-файлы KeePass V1 и V2

Password Safe не может напрямую импортировать XML-файлы, созданные KeePass V1 и KeePass V2, т. к. их формат сильно отличается от используемого в Password Safe. Но мы предоставляем XSL-файлы для преобразования их в совместимый формат (KPV1_to_PWS.xslt и KPV2_to_PWS.xslt). Указанны ниже программы могут быть использованы для обработки экспортированных XML-файлов с помощью XSLT-шаблонов. Полученные в результате преобразования файлы совместимы с импортируемыми Password Safe XML-файлами (для Password Safe V3.26 или новее).

XSLT-файлы соответствуют стандарту XSLT V1.0, описанному на http://www.w3.org/TR/xslt, и были проверены на файлах, созданных с помощью KeePass V1.19b и KeePass V2.15.

Обратите внимание, что в Password Safe значение даты и времени должны быть не позднее 19 января 2038 г. Более поздние даты считаются некорректными, и соответствующие поля не заполняются.

Для данных шаблонов на ОС Windows можно использовать следующие XSLT-процессоры. Приведённые в примерах командные строки предполагают, что

  • Имя шаблона для преобразования XML-файла KeePass в XML-файл Password Safe: KPV1_to_PWS.xslt или KPV2_to_PWS.xslt.
  • Имя входного XML-файла KeePass V1 или V2: KeePassV1.xml или KeePassV2.xml.
  • Имя выходного XML-файла Password Safe: PWS.xml.
  • Все входные или выходные файлы находятся в том же каталоге, что и XSLT-процессор. В противном случае необходимо указать полные пути к файлам.
  1. Утилита командной строки от Microsoft (XSLT Processor Version 4.0). В свойствах файла msxsl.exe указана версия V1.1.0.1 и дата 2001 г., хотя на web-сайте указана версия V2.0 с датой 19 сентября 2004 г. Утилиту можно загрузить с http://www.microsoft.com/downloads. Для работы утилиты требуется Microsoft Core XML Services (MSXML) V4.0. Текущая версия MSXML V6, но V4 обычно присутствует на всех версиях Windows, поддерживаемых Password Safe.

    Для XML-файлов KeePass V1 используется команда:

    msxsl KeePassV1.xml KPV1_to_PWS.xslt -o PWS.xml
    Для XML-файлов KeePass V2 используется команда:
    msxsl KeePassV2.xml KPV2_to_PWS.xslt -o PWS.xml
  2. AltovaXML Community Edition (текущая версия 2011r3). См. http://www.altova.com/altovaxml.html.

    Для XML-файлов KeePass V1 используется команда:

    AltovaXML -xslt1 KPV1_to_PWS.xslt -in KeePassV1.xml -out PWS.xml
    Для XML-файлов KeePass V2 используется команда:
    AltovaXML -xslt1 KPV2_to_PWS.xslt -in KeePassV2.xml -out PWS.xml
  3. Saxon-HE (Home Edition) (текущая версия 9.3.0.5). См. http://saxon.sourceforge.net/. Для Saxon также существует графическая оболочка Kernow. См. http://kernowforsaxon.sourceforge.net/. Формат команды зависит от того, какая используется версия Saxon-HE и/или Kernow (Java или .Net). Для получения дополнительной информации см. документацию к программам.

Все перечисленные программы бесплатны для использования, но Kernow требует регистрации после стократного использования.

Особенности обработки XML-файлов KeePass V1

  • Если имя группы в KeePass содержит точку («.»), то при импорте в Password Safe она будет заменена на косую черту («/»), т. к. в Password Safe точка используется в качестве разделителя групп.
  • Из поля заметок удаляются все символы возврата каретки, а символы новой строки преобразуются в используемый Password Safe разделитель строк '»'.
  • Уникальные идентификатор (UUID) элемента KeePass переносятся в Password Safe без изменений, если только он уже не используются для другого элемента (что бывает очень редко), в противном случае будет создан новый идентификатор.
XML-элементы KeePass V1 | Эквивалентные XML-элементы Password Safe
<group> | <group>
<title> | <title>
<username> | <username>
<password> | <password>
<url> | <url>
<notes> | <notes>
<lastmodtime> | <pmtimex> и <rmtimex>
<creationtime> | <ctimex>
<lastaccesstime> | <atimex>
<expiretime> | <xtimex>, если в KeePass значение атрибута "expires" тега <expiretime> равно «true»
<image> <attachdesc> <attachment> | В Password Safe отсутствуют схожие поля, поэтому они игнорируются

Особенности обработки XML-файлов KeePass V2

  • Значение <HistoryMaxItems> из раздела <Meta> в XML-файле KeePass V2 используется в качестве максимального количества паролей, сохраняемых в истории элемента в Password Safe. Оставшиеся поля из этого раздела игнорируются.
  • Если имя группы в KeePass содержит точку («.»), то при импорте в Password Safe она будет заменена на косую черту («/»), т. к. в Password Safe точка используется в качестве разделителя групп.
  • Из поля заметок удаляются все символы возврата каретки, а символы новой строки преобразуются в используемый Password Safe разделитель строк '»'.
  • Уникальные идентификаторы (UUID) элементов KeePass переносятся в Password Safe, если только они уже не используются для других элементов, в противном случае будет создан новый идентификатор.
  • Если для группы KeePass задано значение <DefaultAutoTypeSequence>, то для элементов этой группы в Password Safe оно будет использоваться как значение автонабора по умолчанию.
  • Если для элемента значение <AutoType> равно «True» и значение <DefaultSequence> не пусто, то последнее используется в Password Safe как последовательность для автонабора. Если для элемента значение <AutoType> равно «True», но значение <DefaultSequence> пусто, то используется значение <DefaultAutoTypeSequence> от родительской группы.
  • Если значение <OverrideURL> не пусто, то оно помещается в заметки с префиксом «OverrideURL:», а к значению поля URL добавляется приставка «[alt]».
  • Если строка URL начинается с «\\» или «cmd://» (независимо от регистра), то значение помещается в поле «Выполнить», но перед этим производится подстановка ключевых последовательностей (см. ниже). В противном случае строка URL подставляется в поле «Ссылка» с предварительной заменой только последовательностей вида {S:FieldName}.
  • Если значение <Tags> не пусто, то оно помещается в заметки с префиксом «Tags:».

KeePass V2 экспортирует значения строковых полей (например, заголовок) в раздел <String> с элементами <Key> и <Value>. Пример:

<String>
    <Key>Title</Key>
    <Value>Заголовок элемента</Value>
</String>

В таблице указаны преобразования элементов этого разделов при импорте в Password Safe.

Значение <String>/<Key> в KeePass V2 | Эквивалент в Password Safe
Title (заголовок) | <title>
Username (имя пользователя) | <username>
Password (пароль) | <password>
URL (ссылка) | <url> или <runcommand> в зависимости от префикса (см. выше)
Notes (заметки) | <notes>
Все остальные | Добавляются в поле «Заметки» в виде: «Key: Value»

KeePass V2 экспортирует все поля, связанные со временем в раздел <Times>. Пример:

<Times>
  <LastModificationTime>2011-05-30T14:20:57Z</LastModificationTime>
  <CreationTime>2011-05-27T18:09:29Z</CreationTime>
  <LastAccessTime>2011-05-30T14:20:57Z</LastAccessTime>
  <ExpiryTime>2999-12-28T23:59:59Z</ExpiryTime>
  <Expires>False</Expires>
</Times>

В таблице указаны преобразования элементов этого разделов при импорте в Password Safe.

Значения времени в KeePass V2 | Эквивалент в Password Safe
<Times>/<LastModificationTime> | <pmtimex> и <rmtimex>
<Times>/<CreationTime> | <ctimex>
<Times>/<LastAccessTime> | <atimex>
<Times>/<ExpiryTime> | <xtimex>, если <Times>/<Expires> равно «True»

KeePass V2 создаёт запись в истории при изменении любого поля элемента. Password Safe отслеживает только изменения пароля. Все остальные изменения, сохранённые в записях истории KeePass, игнорируются.

История KeePass V2 | Эквивалент в Password Safe
<Times>/<LastModificationTime> | <history_entry>/<changedx>
<String[Key='Password']> | <history_entry>/<oldpassword>
Все остальные значения из <History> | Игнорируются

Ниже описаны преобразования кодов автонабора KeePass V2 (см. http://keepass.info/help/base/autotype.html) в коды Password Safe. Все неуказанные коды копируются без изменений.

Коды автонабора KeePass V2 | Эквивалент в Password Safe
\ | \\ (экранирование символа «\»)
Табуляция {TAB} | \t
Enter {ENTER} или ~ | \n
Забой {BACKSPACE}, {BS} или {BKSP} | \b
«+» на цифровой клавиатуре {ADD} | +
«-» на цифровой клавиатуре {SUBTRACT} | -
«*» на цифровой клавиатуре {MULTIPLY} | *
«/» на цифровой клавиатуре {DIVIDE} | /
+ {+} | +
^ {^} | ^
% {%} | %
~ {~} | ~
(, ) {(}, {)} | (, )
{DELAY X} Задержка в X мс. | \wX (\WX)
{DELAY=X} Установка задержки в X мс между нажатиями кнопок в последовательности. | \dX

Ниже описаны ключевые последовательности подстановок KeePass V2 (см. http://keepass.info/help/base/placeholders.html) в коды Password Safe. Все неуказанные коды копируются без изменений.

Ключевые подстановки регистронезависимы. Ссылки на пользовательские строки имеют вид {S:FieldName}. Например, если у элемента задана пользовательская строка «eMail», на неё можно сослаться используя подстановку {S:eMail}.

Подстановки KeePass V2 | Ключи автонабора в Password Safe | Ключи для команд в Password Safe
{GROUP} | \g | ${G}
{TITLE} | \i | ${t}
{USERNAME} | \u | ${u}
{PASSWORD} | \p | ${p}
{NOTES} | \o | ${n}

Подстановки KeePass V2 | Ключи для команд в Password Safe
\{ | \\{ (экранирование «\»)
$ | \$ (экранирование «$»)
{GROUPPATH} | ${g}
{URL} | ${url}
{URL:RMVSCM} | ${url}
{APPDIR} | ${appdir}
{DB_PATH} | ${fulldb}
{DB_DIR} | ${dbdir}
{DB_NAME} | ${dbname}.${dbextn}
{DB_BASENAME} | ${dbname}
{DB_EXT} | ${dbextn}
Все остальные | Копируются без изменений


Экспорт элементов

Password Safe поддерживает экспорт и импорт сохранённых паролей из различных форматов. Для экспорта элементов используйте пункт меню «Файл»→«Экспортировать в». Поддерживаются следующие форматы:

  • Password Safe v1 (для использования в Password Safe версии 1.x)
  • Password Safe v2 (для использования в Password Safe версии 2.x)
  • Простой текст
  • XML

Для экспорта в форматы предыдущих версий Password Safe просто выберите нужный формат и укажите имя контейнера.

Чтобы экспортировать элементы в другой контейнер Password Safe, запустите ещё одну копию Password Safe (должен быть разрешён запуск нескольких экземпляров на вкладке Управление→Настройки→Система) и создайте новый контейнер. Затем перетяните необходимые элементы или группы в новый контейнер.

Для экспорта используется мастер. В нём также можно задать расширенные условия отбора, позволяющие ограничить набор элементов и полей для экспорта. Для получения дополнительной информации см. здесь.

По окончании будет создан отчёт, содержимое которого может быть скопировано в буфер обмена или сохранено на диск в том же каталоге, где находится контейнер. Отчёт можно посмотреть позже с помощью меню Просмотр→Отчёты. Отчёт имеет фиксированное имя, зависящее от его типа. При повторении действия и сохранении отчёта на диск, предыдущий отчёт для этого действия перезаписывается. Примечание. Отчёт может содержать важные данные, поэтому возможность сохранения на диск следует использовать с осторожностью.

Экспорт в текст

Примечание. Экспорт в текстовый формат приводит к созданию незащищённой копии указанных элементов. Простого удаления файла после использования не достаточно для предотвращения доступа злоумышленников к его содержимому, что может быть использовано для обхода защиты, предоставляемой Password Safe. Пожалуйста, НЕ ИСПОЛЬЗУЙТЕ данную функцию если вы не до конца осознаёте возможные риски.

Password Safe позволяет произвести экспорт элементов в текстовый формат. Затем эти файлы могут быть использованы или изменены другими приложениями.

Для подтверждения экспорта данных в незащищённый текстовый файл, будет запрошен мастер-пароль. Если вы используете YubiKey, нажмите кнопку с надписью «YubiKey» и коснитесь кнопки на устройстве YubiKey. Затем будет предложено указать имя нового файла. Если такой файл уже существует, будет выдан запрос о его перезаписи.

Экспорт в текст

Примечание. Если у вас нет YubiKey, соответствующие кнопки и поля не будут отображены.

Также можно указать дополнительные параметры:

  • Поля экспортированных записей («Группа.Заголовок», «Имя пользователя» и «Заметки») будут разделены символом табуляции. «Группа.Заголовок» считается одним полем. Любое значение, содержащее пробел, будет заключено в двойные кавычки. Только поле «Заметки» может состоять из нескольких строк. Обычно, каждая строка заметок записывается в отдельной строке. Но, в данном случае, затрудняется сортировка и сравнение экспортированных файлов. Для упрощения сортировки вы можете указать разделитель, который будет вставляться между строками. Использованный разделитель нужно будет указать при импорте, иначе текст заметок не будет разбит на строки.
    Если требуется, укажите символ для разделения строк с заметками. Так как всё содержимое поля «Заметки» заключено в двойные кавычки, это символ нельзя использовать в качестве разделителя строк.

Расширенные настройки экспорта а в простой текст

Если поставить флажок «Расширенные условия отбора», будет доступна ещё одна страница, на которой можно задать ограничения по значению полей элемента, а также указать поля для экспорта. Для получения дополнительной информации см. здесь.

Примечание. Описание формата экспорта в текстовый файл находится в разделе Формат текстового экспорта и импорта.

XML

XML (eXtensible Markup Language) — распространённый формат для передачи данных между приложениями. Password Safe может экспортировать и импортировать содержимое контейнера в данный формат. Структура (схема) для экспорта и проверки документа определена в файле pwsafe.xsd, который идёт в комплекте с Password Safe. Этот файл используется Password Safe при импорте данных из формата XML и может потребоваться приложениями, которые будут обрабатывать экспортированные данные.

Примечание. Экспорт в текстовый формат приводит к созданию незащищённой копии указанных элементов. Простого удаления файла после использования не достаточно для предотвращения доступа злоумышленников к его содержимому, что может быть использовано для обхода защиты, предоставляемой Password Safe. Пожалуйста, НЕ ИСПОЛЬЗУЙТЕ данную функцию если вы не до конца осознаёте возможные риски.

Отображение XML-файлов в браузере описывается в стилевом файле pwsafe.xsl (XSL — eXtensible Stylesheet Language). Файл, идущий в комплекте с Password Safe, является примером оформления и может быть изменён под ваши нужды. Так как стилевой файл лишь задаёт отображение данных, а не изменяет их, его содержимое не влияет на импорт из XML-файла в контейнер Password Safe.

Как и в настройках экспорта в простой текст, вы можете указать поля для экспорта и сделать отбор по содержимому поставив флажок «Расширенные условия отбора». На следующей странице мастера будет отображён диалог:

Расширенные настройки экспорта в XML

Если поставить флажок «Расширенные условия отбора», будет доступна ещё одна страница, на которой можно задать ограничения по значению полей элемента, а также указать поля для экспорта. Примечание. По XML-схеме требуется, чтобы присутствовали поля «Заголовок» и «Пароль», поэтому их нельзя убрать из списка экспортируемых. Для получения дополнительной информации см. здесь.


Фильтры

Работа с фильтрами производится через меню «Просмотр».

Меню «Фильтры»

Фильтр — это условие или набор условий, которым удовлетворяет или не удовлетворяет элемент. Password Safe позволяет определить фильтры и отобразить лишь те элементы, которые удовлетворяют заданным в них условиям. Вы можете сформировать фильтр для разового использования, или же создать один или несколько именованных фильтров и сохранить их для повторного использования. Фильтры могут быть сохранены внутри контейнера или во внешнем файле (для использования с разными контейнерами).

Создание фильтра

Для создания нового фильтра выберите пункт меню Просмотр→Фильтры→Создать/Редактировать фильтр. Будет отображён следующий диалог:

Диалог настройки фильтра

Каждый фильтр состоит из одной или нескольких строк, каждая из которых описывает условие для указанного поля. Записанное в строке условие, может быть связано с предыдущими логическим «И» или «ИЛИ». С помощью этого можно создать следующие виды фильтров:

  1. Все элементы, с именем пользователя «вася», «Вася» или «ВАСЯ»
    пример 1
  2. Все элементы, с именем пользователя «Вася» (точное совпадение), созданные после 1 мая 2008 года
    пример 2
  3. Все элементы, с именем пользователя, содержащим «Вася» или «Маша»
    пример 3

Как видно из примеров, фильтры могут быть различной сложности.

Описание столбцов фильтра:

  • «#» — номер условия. Отображается для удобства, и не может быть изменён.
  • «?» — флажок в данном столбце определяет, используется данное условие или нет. При отборе записей по фильтру учитываются только те условия, у которых стоят флажки в данном поле. Щелчок в поле устанавливает/снимает флажок.
  • «+» — щелчок по данному полю добавляет новую строку после текущей.
  • «-» — щелчок по этому полю приводит к удалению текущей строки. Примечание. Так условие удаляется навсегда, в некоторых случаях удобнее отключить его, а не удалить.
  • «И / Или» — позволяет определить связь с предыдущим условием.
  • «Поле» — содержит имя поля на которое накладывается условие («Имя пользователя», «Пароль», «Заголовок», «Группа», и пр.).
  • «Условие» — описывает условие, накладываемое на выбранное поле. После выбора поля щелчок в данной ячейке приводит к отображению списка с доступными условиями.

Применение фильтра

После нажатия на кнопку «Применить» производится фильтрация записей, но окно со списком условий остаётся открытым. Это удобно при исправлении и подстройке фильтров. Нажатие на «OK» также применяет фильтр, но закрывает окно с условиями.

Когда фильтр активен, в строке состояния отображается количество показанных элементов и, в скобках, общее количество элементов контейнера. Кроме того, в правом углу появляется значок ( Фильтр активен). При этом, элементы, попавшие под условия фильтра, выделяются красным цветом.

Фильтр для истекающих паролей

Управление фильтрами

Пункт меню «Создать/Редактировать фильтр» удобен для «одноразовых» фильтров. Если же у вас есть фильтры, которые хотелось бы использовать повторно, их можно сохранить воспользовавшись пунктом меню Просмотр→Фильтры→Управление.

Управление фильтрами

Диалоговое окно управления фильтрами содержит две таблицы. В верхней перечислены фильтры, а в нижней — условия, определённые в выбранном фильтре.

  • Для добавления нового фильтра нажмите кнопку «Создать». Это равносильно выбору пункта меню Просмотр→Фильтры→Создать/Редактировать фильтр.
  • Для редактирования существующего фильтра следует выбрать его в верхней таблице и нажать кнопку «Изменить».
  • Для применения существующего фильтра нужно установить для него флажок в столбце «Применить». Обратите внимание, что нельзя применить сразу несколько фильтров.

Сохранение фильтров

Фильтры могут быть сохранены в текущем контейнере или во внешнем XML-файле. Внешние фильтры удобны тем, что их можно использовать в нескольких контейнерах, а фильтры сохранённые внутри контейнера не разглашают потенциально важную информацию, заданную в условиях (части имён, паролей и пр.).

  • Для сохранения фильтра во внешнем файле установите флажок в столбце «Экспорт» и нажмите кнопку «Экспорт».
  • Для сохранения фильтра в текущем контейнере установите флажок в столбце «Копировать в контейнер» и нажмите кнопку «Копировать».
  • Для загрузки фильтра из внешнего файла нажмите кнопку «Импорт».
Примечание.
При старте Password Safe проверяет наличие файла autoload_filters.xml в каталоге с файлом настроек pwsafe.cfg (по умолчанию это каталог, в который был установлен Password Safe). Если такой файл существует, из него автоматически загружаются фильтры. Это удобно, если нужно использовать некоторый набор фильтров во всех контейнерах, и нет желания загружать их вручную каждый раз.


Параметры командной строки

При запуске Password Safe без параметров выдаётся запрос пароля для последнего открытого контейнера. Если контейнеры на этом компьютере ещё не открывались (например, при первом запуске Password Safe), будет предложено создать новый контейнер. Это поведение можно изменить, вызвав Password Safe с параметрами:

  • pwsafe контейнер
    Будет открыт указанный в параметре файл вместо того, что использовался в прошлый раз. Если указано только имя файла (без пути), то поиск файла производится в каталоге, из которого было запущено приложение. Обратите внимание, что если имя файла содержит пробелы, то его нужно заключить в двойные кавычки ("имя файла").
  • pwsafe -r [контейнер]
    Указанный контейнер будет открыт в режиме «только чтение». Если контейнер не указан, будет запрошено имя контейнера, который затем будет открыт в режиме «только чтение».
  • pwsafe -e имя_файла
    Указанный файл будет зашифрован с использованием ключа, полученного из введённого пароля. Примечание. Файл может быть любым. Имя зашифрованного файла останется тем же, а в качестве расширения добавляется «.psf».
  • pwsafe -d имя_файла
    Указанный файл будет расшифрован с использованием ключа, полученного из введённого пароля. Примечание. Данный метод применим только к файлам ранее зашифрованным с использованием параметра «-e».
  • pwsafe -c
    В данном случае приложение будет запущено без контейнера, в том числе не будет выведен стандартный диалог (для открытия контейнера используйте меню «Файл»).
  • pwsafe -s [контейнер]
    Приложение будет запущено «молча» — в свёрнутом виде и без контейнера (если он не указан в параметрах). При разворачивании окна будет выведен диалог открытия контейнера (параметр предназначен для запуска Password Safe через ярлык в меню автозапуска). Примечание. в данном случае значок приложения будет помещён в область уведомлений (трей).
  • pwsafe -m
    Параметр аналогичен «-c», но, дополнительно, запуск производится в свёрнутом виде.

Данные параметры могут оказаться полезными, если вы желаете использовать одни и те же настройки на разных машинах, например, при запуске Password Safe со съёмного диска.

  • -u имя_пользователя
    При запуске, вместо настроек пользователя, вошедшего в систему, будут использоваться настройки, заданные для пользователя имя_пользователя.
  • -h имя_хоста
    При запуске, вместо настроек для текущей машины, Password Safe будет использовать настройки, указанные для имя_хоста.
  • -g файл_настроек
    В данном случае указанный файл будет использован для загрузки и сохранения настроек (вместо файла по умолчанию «pwsafe.cfg»). Если указано только имя файла (без пути), то поиск файла производится в каталоге, из которого было запущено приложение. Обратите внимание, что если имя файла содержит пробелы, то его нужно заключить в двойные кавычки ("имя файла"). Параметр может пригодиться при написании скриптов для запуска с портативного устройства (например, флеш-накопителя). См. также описание переменной окружения PWS_PREFSDIR в разделе Настройки Password Safe.

Кроме того есть несколько параметров начинающихся с «--»:

  • --novalidate
    Не использовать автоматическую проверку целостности при открытии контейнера. Есть несколько обязательных проверок, которые производятся независимо от этого параметра, например проверка уникальности идентификатора элемента и сочетаний Группа/Заголовок/Имя пользователя.
  • --testdump
    Используется для проверки механизма создания минидампов процесса Password Safe.
  • --cetreeview
    Новая функция: позволяет выделять и сравнивать два элемента через меню «Изменить» или контекстное меню элемента. Выделение нескольких элементов поддерживается в простом списке и не поддерживается в древовидном. Данный ключ добавляет в древовидном режиме пункт меню «Сравнить элементы...» и позволяет выбрать второй элемент из отдельного списка. Функционал множественного выделения в древовидном режиме находится в разработке. После его реализации данный параметр будет игнорироваться.


Меню «Файл»

Через меню Файл выполняются действия, связанные с управлением и созданием контейнеров Password Safe.

Создать

Создать новый контейнер Password Safe.

Открыть

Открыть существующий контейнер Password Safe. При открытии файла можно указать режим «только чтение» или «чтение/запись». После открытия контейнера текущий статус отображается в строке состояния. В любой момент времени можно дважды щёлкнуть на этом сегменте строки состояния и переключить режим. Также это можно сделать через меню «Файл». Переключение в режим «чтение/запись» невозможно, если другой пользователь уже открыл контейнер в режиме «чтение/запись». Также вы можете переключить режим доступа к контейнеру через это меню.

Закрыть

Закрыть текущий контейнер, но не выходить из приложения.

Недавно использованные

Данное подменю может содержать список недавно использованных контейнеров. Подменю может быть пустым, если Password Safe запускается в первый раз.

Примечания:

  • Список недавно использованных контейнеров можно очистить нажав на пункт меню Очистить список ранее использованных контейнеров.
  • Количество запоминаемых контейнеров настраивается на вкладке Управление→Настройки→Система. Также там можно настроить отображение списка недавно используемых контейнеров внутри меню «Файл», а не в его подменю.

Сохранить

Сохранить изменения в текущем контейнере. Если с момента предыдущего сохранения не было изменений, или, если контейнер открыт в режиме «только чтение», данный пункт меню будет заблокирован.

Сохранить как

Сохранить текущий контейнер под другим именем или в другом каталоге.

Экспортировать в

Экспортировать содержимое открытого контейнера в другой файл в формате предыдущих версий Password Safe, XML-файл, или как простой текст. Подробная информация о сохранении в другие форматы содержится здесь.

Импортировать из

Импортировать в текущий контейнер содержимое ранее экспортированного или правильно составленного текстового файла, XML-файла или контейнера KeePass V1. Подробная информация об импорте из текстовых форматов содержится здесь.

Слияние

Слияние контейнера Password Safe или резервной копии контейнера («.bak») с текущим контейнером. Заблокировано, если контейнер открыт в режиме «только чтение». Для слияния используется мастер. В нём также можно задать расширенные условия отбора, позволяющие ограничить набор элементов и полей для слияния с текущим контейнером.

Сравнить

Сравнить содержимое открытого контейнера с другим контейнером. Для сравнения используется мастер. В нём также можно задать расширенные условия отбора, позволяющие ограничить набор элементов и полей для сравнения. Подробная информация об отображении результатов содержится здесь.

Синхронизировать

Синхронизировать содержимое открытого контейнера с другим контейнером.

Основное различие между слиянием и синхронизацией состоит в том, что во время слияния все элементы из выбранного контейнера переносятся в открытый. При синхронизации происходит обновление лишь тех элементов, которые присутствуют в открытом контейнере. Для синхронизации используется мастер. В нём также можно задать расширенные условия отбора, позволяющие ограничить набор элементов и полей для синхронизации.

Переключение режимов «только чтение» (R-O) и «чтение/запись» (R-W)

Чтобы защитить контейнера, открытый в режиме «чтение/запись» (по умолчанию), от случайных изменений, выберите пункт меню Переключить в режим только чтение (R-O). Аналогично, контейнер, открытый в режиме «только чтение» может быть переведён в режим «чтение/запись» выбором пункта меню Переключить в режим чтение/запись (R-W). При переключение в режим «чтение/запись» будет запрошен мастер-пароль. Также, для переключения между этими режимами можно дважды щёлкнуть на надписи R-W (R-0) в строке состояния.

Примечание. При работе с большими контейнерами операции слияния, сравнения и синхронизации могут занять значительное время.

Свойства

Отображение информации о текущем контейнере: версия формата файла, количество групп, количество элементов, данные о том, когда и кем было произведено последнее сохранение.

Выход

Закрытие Password Safe. Если с момента последнего сохранения контейнер был изменён, вам будет предложено сохранить его.

Отчёты

Примечание. По окончании сравнения, экспорта, импорта и синхронизации создаётся отчёт, содержимое которого можно просмотреть и скопировать в буфер обмена или сохранить на диск в том же каталоге, где находится контейнер. Отчёт можно посмотреть позже с помощью меню Просмотр→Отчёты. Отчёт имеет фиксированное имя, зависящее от его типа. При повторении действия и сохранении отчёта на диск, предыдущий отчёт для этого действия перезаписывается. Примечание. Отчёт может содержать важные данные, поэтому возможность сохранения на диск следует использовать с осторожностью.


Меню «Изменить»

Элемент | Псевдоним | Группа
Вид меню для обычного элемента | Вид меню для псевдонима | Вид меню для группы

Используя меню Изменить вы можете добавлять, редактировать, использовать и упорядочивать имена пользователей и пароли. Обратите внимание, что состав меню зависит от того, что сейчас выбрано в списке (элемент, псевдоним или группа). Кроме того, как указано ниже, некоторые элементы могут быть недоступны.

Добавить элемент

Добавление нового имени и пароля. Недоступно, если контейнер открыт в режиме «только чтение».
Для получения дополнительной информации см. Имена пользователей, пароли и группы.

Редактировать элемент / Развернуть/свернуть группу

Если выбран элемент, открывает диалог редактирования текущей записи. Если при древовидном просмотре выбрана группа, сворачивает или разворачивает список элементов для текущей группы. Редактирование заблокировано, если контейнер открыт в режиме «только чтение».
Для получения дополнительной информации см. Имена пользователей, пароли и группы.

Удалить элемент / Удалить группу

Если выбран элемент, он будет удалён. Если в древовидном списке выбрана группа, то группа и все элементы внутри неё будут удалены. При удалении группы из нескольких элементов выдаётся запрос подтверждения. Пункт заблокирован, если контейнер открыт в режиме «только чтение».

Переименовать элемент / Переименовать группу

Изменение имени элемента или группы (при древовидном просмотре). Пункт заблокирован, если контейнер открыт в режиме «только чтение».

Поиск

Поиск элемента, содержащего указанный текст. По умолчанию поиск производится по всем полям, за исключением пароля.
Для получения дополнительной информации см. Поиск указанного текста.

Дублировать элемент

Создание дубликата выбранного элемента. Пункт заблокирован, если контейнер открыт в режиме «только чтение».

Добавить группу

Создание новой группы (например, «Пароли для банковских систем»). Пункт заблокирован, если контейнер открыт в режиме «только чтение».

Вернуть

Отмена последнего действия. При повторных нажатиях отмена производится в обратном порядке (от последнего действия к первому).

Повторить

Последнее отменённое действие (действия) будет выполнено снова.

Очистить буфер обмена

Очистка содержимого буфера обмена. Из буфера удаляются все данные, помещённые туда Password Safe (имена, пароли, заметки, ...). Не оказывает действия, если содержимое буфера не принадлежит Password Safe.

Копировать пароль в буфер обмена

Копирование пароля выбранного элемента в буфер обмена.

Показать часть пароля

При выборе данного пункта отображается окно, позволяющее задать символы, которые необходимо показать. Данная функция может быть полезна для сайтов, требующих ввода части пароля. Например, вас могут попросить ввести первый, третий, пятый и восьмой символы. В верхнем поле нужно указать позиции необходимых символов. В качестве разделителя можно использовать пробелы, запятые и точки с запятой. Соответствующие символы будут показаны в нижнем поле. Выход производится по кнопке Esc.

Копировать имя пользователя в буфер обмена

Копирование имени пользователя из текущего элемента в буфер обмена.

Копировать заметки в буфер обмена

Копирование содержимого заметок из текущего элемента в буфер обмена.

Копировать ссылку в буфер обмена

Копирование ссылки, связанной с текущим элементом, в буфер обмена.

Копировать E-mail в буфер обмена

Копирование E-mail, связанного с текущим элементом, в буфер обмена.

Копировать команду в буфер обмена

Копирование команды для текущего элемента в буфер обмена.

Примечание. Значение переменных не будет подставлено, если при выборе пункт меню был нажат Ctrl.

Перейти по ссылке

Если для текущего элемента указана ссылка, открывает её в браузере по умолчанию. Пункт меню недоступен, если элемент не выбран, или для него не задана ссылка.

Если в диалоге Управление→Настройки→Безопасность не указано иное, пароль автоматически копируется в буфер обмена.

Перейти по ссылке и выполнить автонабор

Если для текущего элемента указана ссылка, открывает её в браузере по умолчанию. Пункт меню недоступен, если элемент не выбран, или для него не задана ссылка.

Автоматически вводит имя пользователя и пароль в выбранные поля.
Для получения дополнительной информации см. Автонабор.

Отправить письмо

Подготовка нового письма по данным, указанным в поле E-mail. Перед использованием убедитесь, что на компьютере установлен почтовый клиент.
Для получения дополнительной информации см. Имена пользователей, пароли и группы.

Автонабор

Автоматически вводит имя пользователя и пароль в выбранные поля.
Для получения дополнительной информации см. Автонабор.

Выполнить команду

Запуск команды, указанной в поле Выполнить текущего элемента.
Для получения дополнительной информации см. Выполнение команд.

Создать ярлык

Если выбран элемент, позволяет создать ссылку на этот элемент (обычно в другой группе). Ярлыки удобно использовать если элемент «принадлежит» к нескольким группам, но вы не желаете дублировать данные. Для отображения ярлыков используется другой значок ( ярлык) и, по умолчанию, имя имеет вид «ярлык для x», где x — имя исходного элемента. Как и в случае с обычным элементом, ярлык можно будет переместить, удалить или переименовать.

Перейти к исходному элементу

Данный пункт отображается только для ярлыков и псевдонимов. После выбора пункта Перейти к исходному элементу происходит переход к соответствующему исходному элементу.

Редактировать исходный элемент

Данный пункт отображается только для ярлыков и псевдонимов. После нажатия Редактировать исходный элемент вы сможете произвести изменения в соответствующем исходном для выбранного ярлыка или псевдонима элементе.

Экспортировать элемент в простой текст

Экспорт выбранного элемента в текстовый файл. Для подтверждения экспорта данных в незашифрованный файл, будет предложено ввести мастер-пароль.
Для получения дополнительной информации см. Экспорт элементов.

Экспортировать элемент в XML формат

Экспорт выбранного элемента в XML формат. Для подтверждения экспорта данных в незашифрованный XML-файл, будет предложено ввести мастер-пароль.
Для получения дополнительной информации см. Экспорт элементов.

Защитить элемент / Защитить все элементы

Выбранный элемент или группа элементов будут защищены. Защищённый элемент не может быть изменён. Защищённые элементы отмечены символом «#».

Действия по нажатию правой кнопки мыши

Все функции меню Изменить доступны через контекстное меню (при нажатии правой кнопкой мыши) элемента, псевдонима или группы.

Элемент | Псевдоним | Группа
Контекстное меню элемента | Контекстное меню псевдонима | Контекстное меню группы

Все функции описаны в предыдущем разделе.


Меню «Просмотр»

Меню «Просмотр»

Через меню Просмотр можно управлять настройками отображения. Здесь можно выбрать режим отображения элементов: в виде простого списка (Простой список) или сгруппированного по категориям (Древовидный список). Также здесь можно скрыть или отобразить панель инструментов и выбрать стиль значков для неё. Сама панель инструментов тоже может быть настроена. Кроме того, вы можете свернуть или развернуть все группы в дереве, отфильтровать элементы по какому-либо условию, выбрать шрифт для отображения элементов или просмотреть отчёты о сложных операциях, таких как слияние, сравнение, импорт.

Переключение между режимами просмотра

  1. Откройте меню Просмотр
  2. Выберите Древовидный список или Простой список

Управление панелью инструментов

Для отображения или скрытия панели инструментов поставьте или снимите отметку с пункта меню Отобразить панель инструментов.
Для использования «современного» или «классического» набора значков, выберите Современная панель инструментов или Классическая панель инструментов соответственно.

Отобразить панель Dragbar

Панель Dragbar является специальной панелью, позволяющей вставлять некоторые значения, связанные с текущим элементом, перетаскивая соответствующий значок с этой панели в нужное поле окна другого приложения. Например, для того, чтобы вставить текст заметок элемента в другое приложение с помощью панели «Dragbar», нужно выделить элемент и перетащить значок с листком (в «классическом» интерфейсе с буквой «N») в окно приложения. Когда вы отпустите левую кнопку мыши, содержимое заметок будет вставлено в выбранное поле того приложения. Для незаполненных полей элемента, соответствующие значки на панели «Dragbar» заблокированы (серые).
Кнопка «Автонабор» ведёт себя по-другому: перетаскивание её в область ввода другого окна (например, браузера) приведёт к началу автонабора в этом поле.

Примечания:

  • Похоже, что в Internet Explorer (V7, V8 и V9) автонабор с панели «Dragbar» работает не совсем корректно: теряются символы до первой табуляции. Этого не происходит с браузерами Firefox и Chrome. Поэтому только при автонаборе с панели «Dragbar» сначала посылается символ табуляции, а затем Shift+Tab (чтобы обратно вернуться в поле ввода). Побочный эффект этого трюка приводит к тому, что автонабор с панели «Dragbar» заменяет значение поля, а не добавляет ввод к нему. В окнах других приложений результат зависит от того, как обрабатываются символы Tab и Shift+Tab.
  • Если при щелчке на значке панели «Dragbar» нажата клавиша Сontrol, соответствующий текст дополнительно будет помещён в буфер обмена. Это может быть удобно, если при перетаскивании вы «промахнулись» на пару пикселей: в этом случае вместо повторного перетаскивания вы можете скопировать данные из буфера обмена.

Для того, чтобы скрыть или отобразить панель «Dragbar» поставьте или снимите отметку на пункте меню Отобразить панель Dragbar.

Развернуть все

Развернуть все группы, делая видимыми все элементы (только для древовидного списка).

Свернуть все

Свернуть все группы (при древовидном просмотре).

Обновить F5

При выборе этого пункта меню или нажатии на клавишу F5 будет произведено обновление окна.

Отобразить несохранённые изменения

Если на вкладке Управление→Настройки→Резервные копии снят флажок Сохранять контейнер после вставки или редактирования, изменения не сохраняются автоматически, а выделяются цветом. Ниже приведены изображения с примерами.

Видны все элементы:
Контейнер с несохранёнными изменениями

После пометки данного пункта меню будут отображены только элементы с несохранёнными изменениями.

Видны только изменённые элементы:
Только несохранённые изменения.

Примечание. Когда в контейнере присутствуют несохранённые изменения, в строке статуса отображается символ «*».

Показать элементы с заданными датами истечения пароля

Если выбран этот пункт меню, в списке отображаются только те элементы, у которых задана дата истечения пароля. При этом не важно, находится ли дата истечения пароля в прошлом или будущем.

Пункт меню неактивен, если отсутствуют элементы с заданными датами истечения пароля.

Фильтр для истекающих паролей

Фильтры

Фильтр — это условие или набор условий, которым удовлетворяет или не удовлетворяет элемент. Password Safe позволяет определить фильтры и отобразить лишь те элементы, которые удовлетворяют заданным в них условиям. Для получения дополнительной информации об использовании фильтров см. здесь.

Изменить шрифт

Изменение шрифтов

Данное подменю позволяет задать шрифт для отображения элементов в «простом» и «древовидном» списках, а также шрифт для отображения паролей в диалогах добавления и редактирования элементов. Кроме того, можно изменить шрифт для экранной клавиатуры. Этот шрифт должен поддерживать символы Unicode. Например, это может быть шрифт «Arial Unicode MS» (поставляется вместе с Microsoft's Office), «Arial Unicode» или «Lucida Sans Unicode». Но, вы можете задать и другой шрифт в соответствующем пункте меню.

Отчёты

Просмотр отчётов

Сохранённые отчёты об операциях сравнения, экспорта, импорта, поиска, слияния и синхронизации создаются в том же каталоге, где находится контейнер. При повторении операции и сохранении отчёта на диск, предыдущий отчёт для этой операции перезаписывается. Отчёты можно просмотреть позже, если контейнер останется в том же каталоге.


Меню «Управление»

Меню «Управление»

Через меню Управление производится настройка всех параметров Password Safe.

Изменить пароль для контейнера

Изменение мастер-пароля для контейнера.

Для получения дополнительной информации см. Изменение мастер-пароля для контейнера.

Создать резервную копию

Создание резервной копии текущего контейнера.

Для получения дополнительной информации см. Резервное копирование и восстановление контейнеров.

Восстановить из резервной копии

Восстановление контейнера из резервного копии:

Для получения дополнительной информации см. Резервное копирование и восстановление контейнеров.

Настройки

При выборе данного пункта будет отображён диалог, с помощью которого можно просматривать и редактировать настройки Password Safe. Для получения информации о настройках на той или иной вкладке перейдите по соответствующей ссылке.

«Резервные копии»
«Отображение»
«Разное»
«История паролей»
«Безопасность»
«Комбинации клавиш»
«Система»
Примечание.
Особенности сохранения настроек описаны здесь.

Политики создания паролей...

Позволяет управлять политикой паролей по умолчанию и именованными политиками паролей. Вы можете создать до 255 именованных политик. Длина имени политики не должна превышать 255 символов.

Настроить основную панель инструментов

Выбор и перестановка команд, отображаемых на панели инструментов.

Создать пароль

Создание пароля согласно выбранной политики и копирование его в буфер обмена. Пароль из буфера обмена может быть использован в других приложениях. Для создания пароля вы можете выбрать политику по умолчанию, именованную политику, или явно задать требуемые параметры.

YubiKey

Здесь вы можете настроить ключ YubiKey для доступа к контейнеру Password Safe, или создать его резервную копию, на случае повреждения или утери.

Настройки YubiKey

Для настройки YubiKey

  1. Подключите YubiKey к USB-порту ПК.
  2. Выберите пункт меню «Управление→YubiKey...». Будет отображён диалог настройки YubiKey.
  3. В нём вы должны увидеть серийный номер вашего устройства. Если поле пустое, убедитесь что устройство правильно подключено.
  4. Нажмите кнопку «Создать». Будет сгенерирована 20-байтная случайная последовательность, которая затем будет записана в YubiKey и использована при доступе к контейнеру.
  5. Нажмите кнопку «Сохранить». При выполнении этого действия созданный ключ будет записан в YubiKey, а его зашифрованная копия в контейнер Password Safe (чтобы его затем можно было использовать при создании резервной копии).
  6. При успешном завершения окно будет закрыто. В противном случае, будет отображено сообщение об ошибке.
  7. Для выхода из диалога настроек нажмите кнопку «Закрыть».
Примечание. Чтобы использовать YubiKey для аутентификации, после проведения настройки необходимо сменить мастер-пароль контейнера. Порядок изменения мастер-пароля описан описан в разделе Изменение мастер-пароля для контейнера.

Создание резервной копии YubiKey

  1. Подключите запасной YubiKey к USB-порту ПК.
  2. Выберите пункт меню «Управление→YubiKey...». Будет отображён диалог настройки YubiKey.
  3. В нём вы должны увидеть серийный номер вашего резервного устройства. Если поле пустое, убедитесь что устройство правильно подключено.
  4. Не нажимайте на кнопку «Создать». Последовательность, отображённая в поле «Секретный ключ YubiKey» это ключ, связанный с контейнером. Этот ключ будет записан на резервный YubiKey.
  5. Нажмите кнопку «Сохранить». Произойдёт сохранение ключа на резервное устройство.
  6. При успешном завершения окно будет закрыто. В противном случае, будет отображено сообщение об ошибке.
  7. Для выхода из диалога настроек нажмите кнопку «Закрыть».

Изменить язык

Изменить язык

Если у вас установлены дополнительные языковые модули (устанавливаются по умолчанию), с помощью этого меню можно переключать язык программы на лету.

После изменения языка все меню, диалоги и сообщения будут отображаться на выбранном языке.


Меню «Помощь»

Меню Помощь предоставляет доступ к различным ресурсам связанным с Password Safe.

Помощь (F1)

Открывает данный файл со справкой.

Посетить сайт Password Safe

Открывает домашнюю страницу Password Safe в браузере.

О Password Safe

Данный пункт меню отображает окно с информацией о версии и лицензии на распространение исходного кода. Также здесь вы можете проверить наличие новых версий Password Safe. Из соображений безопасности Password Safe закроет текущий контейнер перед проверкой информации о новой версии.

Диалог «О Password Safe»


Панель инструментов

Доступно два стиля отображения значков на панели инструментов: «современный» и «классический». Для каждого значка на панели инструментов доступны всплывающие подсказки. Для отображения подсказки достаточно навести мышку на значок. Для удобства ниже приведено краткое описание значков.

Начиная с версии 3.11 можно изменить набор значков и порядок их отображения на панели.

Переключение между стилями отображения значков

  1. Откройте меню Просмотр.
  2. Выберите Классическая панель инструментов или Современная панель инструментов.

Список значков

Классический стиль | Современный стиль | Значение по умолчанию | Описание
 |  | X | Создать новый контейнер
 |  | X | Открыть другой контейнер
 |  | X | Закрыть текущий контейнер
 |  | X | Сохранить изменения в текущем контейнере
 |  |  | Сохранить изменения в контейнере с другим именем
 |  | X | Скопировать пароль выбранного элемента в буфер обмена
 |  | X | Скопировать имя пользователя в буфер обмена
 |  | X | Скопировать заметки для текущего элемента в буфер обмена
 |  | X | Очистить буфер обмена
 |  | X | Выполнить автонабор для текущего элемента
 |  | X | Перейти по ссылке, указанной в элементе
 |  |  | Перейти по ссылке, указанной в элементе, и выполнить автонабор
 |  | X | Создать новый элемент в текущем контейнере
 |  | X | Открыть выбранный элемент для редактирования
 |  | X | Удалить выбранный элемент
 |  |  | Переключить режима просмотра (список/дерево)
 |  | X | Свернуть все группы (при древовидном просмотре)
 |  | X | Развернуть все группы (при древовидном просмотре)
 |  |  | Сравнить текущий контейнер с другим
 |  |  | Слияние текущего контейнера с другим
 |  |  | Экспортировать в текстовый файл
 |  |  | Экспортировать в XML-файл
 |  |  | Импортировать данные из текстового файла
 |  |  | Импортировать данные из XML-файла
 |  |  | Просмотр отчётов об операциях импорта и слияния
 |  | X | Изменить настройки
 |  | X | Открыть файл справки
 |  |  | Выполнить команду
 |  |  | Показать часть пароля
 |  |  | Управление фильтрами
 |  |  | Редактировать фильтры
 |  |  | Задать/очистить фильтры
 |  |  | Отобразить панель поиска
 |  |  | Отправить письмо
 |  |  | Синхронизировать текущий контейнер с другим
 |  |  | Отменить последнее действие
 |  |  | Повторить последнее отменённое действие
 |  |  | Управление политиками создания паролей


Вкладка «Отображение»

Параметры на вкладке Отображение влияют на вид Password Safe и элементов контейнера.

Отображать Password Safe поверх всех окон

Если помечено, развёрнутый Password Safe будет находиться поверх всех окон, независимо от того, какое окно имеет фокус ввода.

Отображать имя пользователя в дереве

Если помечено, имя пользователя будет отображаться в квадратных скобках после имени элемента (в режиме древовидного списка).

Отображать пароль в дереве

Если помечено, пароль будет отображаться в фигурных скобках после имени пользователя (в режиме древовидного списка). Строго не рекомендуется использовать данный параметр, если во время работы возможен просмотр экрана посторонними людьми.

Отображать заметки во всплывающей подсказке

Если помечено, заметки будут отображаться при наведении курсора мыши на элемент.

Отображать пароль при добавлении и редактировании

Если помечено, скрытый по умолчанию пароль в диалогах добавления и просмотра/редактирования будет видимым. Вы можете отобразить или скрыть пароль текущего элемента, нажав в диалоге кнопку «Показать/Скрыть».

Отображать заметки при редактировании

Если помечено, в диалоге редактирования заметки будут видимыми по умолчанию. В противном случае, для отображения нужно будет щёлкнуть по полю ввода заметок.

При редактировании переносить заметки по словам

Если помечено, в поле заметок будет использоваться перенос по словам. Иначе, при недостатке ширины, будет отображаться горизонтальная полоса прокрутки.

Отображать сетку списка

Если помечено, будут видны светлые линии сетки, и список станет похож на таблицу.

Отображать группы вверху дерева

По умолчанию в древовидном списке элементы отсортированы по алфавиту. Если данная опция активна, группы будут расположены вверху (в алфавитном порядке), а за ними пойдут остальные элементы соответствующего уровня.

Выделить изменённые элементы

Изменённый элемент до момента сохранения будет выделен цветом. Если на вкладке «Резервные копии» поставлен флажок «Сохранять контейнер после вставки или редактирования», элементы никогда не будут помечены, так как сохранение происходит немедленно.

Предупреждать за N дней до истечения пароля

Если помечено, при чтении контейнера (обычно при запуске) Password Safe будет просматривать все элементы и уведомлять, если пароль истекает не позднее чем через N дней.

Вид дерева при старте

Определяет, как отображать элементы при открытии контейнера в режиме древовидного списка.

Значок в области уведомлений

Позволяет указать цвет значка Password Safe в области уведомлений (трее), когда контейнер не открыт.


Вкладка «Разное»

Вкладка «Разное»

На вкладке Разное настраиваются действия и значения по умолчанию.

Подтверждать удаление элементов

Если помечено, при удалении элемента будет выводится запрос подтверждения.

Сохранять время последнего доступа к записи

Если помечено, Password Safe будет записывать время доступа к элементу (копирование пароля, просмотр данных элемента и пр.). Время хранится вместе с элементом и может быть просмотрено в диалоге редактирования/просмотра элемента.

Примечания:
  • В данном случае контейнер будет изменяться даже если элементы не редактировались. Поэтому, при закрытии контейнера вам будет предложено сохранить изменения, даже если вы ничего явно не изменяли.
  • Если контейнер открыт в режиме «только чтение», время последнего доступа не обновляется.

Закрывать приложение по Esc

Если помечено, клавиша Esc закрывает Password Safe. Обратите внимание, что если активна настройка «Отображать значок в области уведомлений», то клавиша Esc лишь скрывает окно. Его можно открыто двойным щелчком по значку в области уведомлений.

По двойному клику

Позволяет установить действие, которое Password Safe будет выполнять при двойном щелчке на элементе. Действием по умолчанию является копирование пароля в буфер обмена. Возможные следующие действия:

  • Автонабор
  • Перейти по ссылке
  • Перейти по ссылке и выполнить автонабор
  • Копировать заметки в буфер обмена
  • Копировать пароль в буфер обмена
  • Копировать пароль в буфер и свернуть
  • Копировать имя пользователя в буфер
  • Выполнить команду
  • Отправить письмо
  • Просмотр/редактирование элемента

Обратите внимание, что поведение «Копировать пароль в буфер и свернуть» будет не таким, как ожидалось, если на вкладке Безопасность включена настройка «Очищать буфер обмена при сворачивании».

Автонабор

  • Свернуть после автонабора По умолчанию, Password Safe сворачивает окно при выполнении автонабора. Если флажок снят, вместо сворачивания Password Safe будет перемещать своё окно на задний план.
  • Строка автонабора по умолчанию Здесь можно указать строку автонабора, применяемую по умолчанию. При необходимости вы можете переопределить её в настройках элемента. Например, данную настройку можно использовать для изменения задержки автонабора всех элементов. Для получения дополнительной информации об автонаборе см. здесь.
  • Задержка между символами Определяет время ожидания (в миллисекундах) перед автонабором следующего символа в последовательности. Значение по умолчанию (10 мс) подходит для большинства систем. Но вы можете уменьшить его (сделать автонабор быстрее), если у вас мощный компьютер, или, наоборот, увеличить (замедлить автонабор) для старых машин. Описание того, как настроить задержку ввода для конкретного элемента, приведено в разделе Автонабор.

Имя пользователя по умолчанию

Данная настройка позволяет указать имя пользователя, подставляемое при создании нового элемента. Если помечено, указанное имя будет по умолчанию подставляться в новые элементы. При создании элемента вы можете изменить это имя.

Альтернативный браузер

Указанный здесь браузер будет использован при выполнении команды «Перейти по ссылке», если в настройках элемента ссылка начинается с «[alt]», например, «[alt]http://www.foo.net». Данный функционал может потребоваться, например, если в качестве браузера по умолчанию настроен Firefox, а связанный с элементом сайт лучше работает в Internet Explorer. В этом случае необходимо указать Internet Explorer как альтернативный браузер («C:\Program Files\Internet Explorer\iexplorer.exe»).

Параметры командной строки для браузера указываются в поле «параметры командной строки».


История паролей

Вкладка «История паролей»

История паролей

При изменении пароля элемента Password Safe может сохранять предыдущее значение. Это может пригодится в том случае, когда смена пароля на соответствующем сайте завершается ошибкой. Данная настройка указывает, нужно ли по умолчанию включать сохранение предыдущих паролей для новых элементов. Данную настройку можно переопределить при добавлении или редактировании элемента.

Хранить N предыдущих паролей для элемента

Установка данного флажка задаёт количество сохраняемых по умолчанию паролей для новых элементов.

Управление историей паролей для существующих элементов

Данный раздел позволяет управлять настройками ведения истории паролей для уже созданных элементов:
  • Без изменений — настройки сохранения предыдущих паролей не изменяются.
  • Перестать сохранять предыдущие пароли — равносильно снятию флажка «Хранить N предыдущих паролей» для всех элементов контейнера. Обратите внимание, что существующая история будет потеряна, и изменения паролей в этих элементах не будут отслеживаться до момента повторного включения.
  • Начать сохранять предыдущие пароли — равносильно установке флажка «Хранить N предыдущих паролей» для всех элементов контейнера. Элементы, история для которых не сохранялась, будут запоминать указанное количество предыдущих паролей. Элементы, ведущие историю паролей, продолжат сохранять изменения, при этом количество сохраняемых паролей не будет изменено.
  • Установить максимальное количество сохраняемых паролей равным указанному значению — все элементы будут хранить указанное количество паролей. Но, если у каких-либо элементов ранее было указано большее значение, история не будет потеряна.


Вкладка «Безопасность»

На данной вкладке можно изменить пользовательские настройки безопасности.

Очищать буфер обмена при сворачивании

Если помечено, при сворачивании окна программы будет произведена очистка буфера от данных, помещённых туда Password Safe (например, имя пользователя, пароль и пр.). В этом случае никто не сможет прочитать то, что было записано в буфер. Обратите внимание, что использование данной опции вместе со «Свернуть после копирования пароля» на вкладке Разное приведёт к неожиданным результатам (пароль будет скопирован в буфер и сразу же удалён оттуда).

Очищать буфер обмена при выходе

Если помечено, при закрытии окна программы будет произведена очистка буфера от данных, помещённых туда Password Safe (например, имя пользователя, пароль и пр.). В этом случае никто не сможет прочитать то, что было записано в буфер.

Подтверждать копирование элемента в буфер обмена

Если помечено, Password Safe каждый раз будет запрашивать разрешение на копирование пароля в буфер обмена.

Блокировать контейнер при сворачивании

Если помечено, при сворачивании программы контейнер будет блокироваться. Для доступа к контейнеру после открытия окна нужно будет ввести мастер-пароль.

Блокировать контейнер при блокировке компьютера

Если данная настройка включена, контейнер будет блокироваться при блокировке компьютера. Её можно использовать для предотвращения несанкционированного доступа к контейнеру лиц, имеющих доступ к рабочей станции.

Блокировать контейнер после

Если включено, Password Safe будет блокировать контейнер по истечении указанного времени с момента выполнения последнего действия с программой.

«Перейти по ссылке» копирует пароль в буфер обмена

По умолчанию, при переходе по ссылке Password Safe копирует пароль элемента в буфер обмена, чтобы его сразу можно было вставить в нужное поле. Но некоторым сайтам требуются другие данные (или они не требуются вообще). После снятия флажка Password Safe перестанет помещать пароль в буфер обмена при переходе по ссылке.

Сложность перебора для мастер-пароля

Положение ползунка определяет количество вычислительных ресурсов, требуемых для открытия и сохранения контейнера Password Safe. Значение обычная предоставляет достаточный уровень стойкости к перебору без заметного замедления открытия контейнера на большинстве платформ. При увеличении этого значения учитывайте самый медленный компьютер, на котором будет использоваться данный контейнер.


Вкладка «Система»

Вкладка «Система» позволяет задать настройки, связанные с взаимодействием Password Safe и ОС.

Отображать значок в области уведомлений

Если помечено, Password Safe будет сворачиваться в значок в области уведомлений (трее). Если флажок снят, при сворачивании Password Safe будет оставаться панели задач.

Значок в области уведомлений показывает, является ли контейнер заблокированным ( заблокирован) или открытым ( разблокирован). Если контейнер заблокирован, вас попросят ввести мастер-пароль при разворачивании окна приложения.

Хранить N использованных элементов в меню значка

Если установлен флажок Отображать значок в области уведомлений, вы можете щёлкнуть правой кнопкой мыши на значке и выбрать один из недавно использованных элементов без отображения главного окна программы. Данная опция позволяет задать количество элементов, сохраняемых в этом списке.

Скрывать значок (должна быть задана горячая клавиша)

Если помечено, Password Safe будет скрывать значок в области уведомлений. Данная функция доступна только в том случае, если задана комбинация клавиш, позволяющая отобразить окно Password Safe.

Запускать Password Safe при входе в систему

Если помечено, при входе в систему Password Safe будет автоматически запускаться и помещаться в область уведомлений. Примечание. Мастер-пароль будет запрошен только тогда, когда вы дважды щёлкнете по значку левой кнопкой.

Недавно использованные контейнеры

Здесь вы можете указать количество запоминаемых контейнеров, отображаемых в меню «Файл». Примечание. Для вступления изменений в силу необходимо перезапустить Password Safe.

Отображать недавно использованные контейнеры в меню Файл, а не в подменю

Данная настройка управляет расположением списка недавно использованных контейнеров (внутри самого меню «Файл» или в подменю).

По умолчанию открывать контейнер только для чтения

Если помечено, Password Safe будет по умолчанию отрывать контейнеры в режиме «только чтение». Данная настройка может пригодиться, если контейнером пользуются несколько людей, так как по умолчанию Password Safe разрешает запись первому, открывшему контейнер, и блокирует изменения для остальных. С её помощью вы сможете сами выбрать, кто должен иметь права на запись.

Разрешить одновременный запуск нескольких копий (для применения требуется перезапуск всех копий программы)

Убрать настройки Password Safe из реестра Windows

До версии 3.05, Password Safe использовал реестр Windows для хранения некоторых настроек (список ранее открытых контейнеров, изменённые настройки, и пр.). Начиная с версии 3.05 настройки были разбиты на две группы: связанных с контейнером (хранятся в контейнере) и связанные с пользователем/машиной (хранятся в отдельном файле настроек). Настройки будут удалены из реестра после установки флажка и нажатия кнопки Применить. Данный функционал может быть использован для удаления следов Password Safe с вашего компьютера. Но, в случае, если вы будете использовать более старые версии, некоторые настройки Password Safe примут своё изначальное значение.

Примечания:

  • Если предыдущие версии Password Safe не использовались на данном компьютере, или, если данные из реестре были удалены ранее, флажок и кнопка Применить будут скрыты.
  • Реестр будет использован лишь в тех редких случаях, когда Password Safe не сможет создать или произвести запись в файл с настройками.

Переместить файл настроек в каталог пользователя

До версии 3.22, Password Safe сохранял изменения настроек (пользовательские настройки, список ранее открытых файлов, размеры окон и пр.) в том же каталоге, где находился исполняемый файл (pwsafe.exe). В новых версиях Windows это вызвало ряд проблем, связанных с тем что пользователи не имеют прав на запись в этот каталог. Поэтому, начиная с версии 3.22, файл настроек (pwsafe.cfg) создаётся в стандартном для файлов такого рода месте — в профиле пользователя внутри каталога «Application Data».

При обновлении версии существующий файл настроек не переносится автоматически («если что-то работает, не трогай это»). Но, если вы хотите перенести настройки, нужно поставить флажок и нажать кнопку «Применить».

Файл с настройками поддерживает хранение настроек нескольких пользователей, возможно, работающих с разных машин. Данная функция производит перенос настроек текущего пользователя (связанных с данным компьютером) в файл по новому пути. Если присутствуют настройки для других пользователей/компьютеров, они останутся в исходном файле. Если же после переноса настроек файл окажется пустым, он будет удалён.

Если Вы желаете использовать общий файл настроек для нескольких пользователей/компьютеров, оставьте его в том же каталоге, где находится исполняемый файл, или укажите путь к нему при запуске (через ключ «-g файл_настроек», описанный в справке по параметрам командной строки).


Вкладка «Комбинации клавиш»

Комбинации клавиш
Password Safe позволяет определить комбинации клавиш (горячие клавиши) для выполнения различных действий внутри приложения. Здесь вы можете управлять назначением клавиатурных комбинаций.

Горячая клавиша для вызова программы

Если выбрано, указанная комбинация клавиш будет использована для восстановления Password Safe из скрытого состояния, или помещения его окна на передний план, когда оно перекрыто другими окнами. Комбинация клавиш может быть изменена при установке флажка для данной настройки.

Горячие клавиши пунктов меню

Чтобы изменить или задать комбинацию клавиш, выберите строку с необходимым действием и щёлкните в поле «Комбинация...». Выбранная комбинация клавиш будет назначена для вызова данного действия. Например, для вызова диалога с информацией о файле по комбинации «Control+Alt+p», выберите строку "Файл » Свойства", щёлкните в поле «Комбинация» и затем нажмите клавиши «Control», «Alt» и «p». Текст «Ctrl+Alt+P» появится в поле «Комбинация...» выбранной строки. Изменения вступят в силу после нажатия «OK». Подробнее о том, какие комбинации можно (или нельзя) использовать для назначения «горячих клавиш» см. здесь.

Вы можете задать комбинацию там, где она ещё не определена, или изменить ранее заданную комбинацию. Комбинации клавиш сохраняются в файле настроек и будут доступны при последующих запусках Password Safe.

Для отмены указанного сочетания клавиш, или возврата к значению по умолчанию, щёлкните правой кнопкой мыши в поле «Комбинация...». В отображённом контекстном меню можно будет выбрать требуемое действие. Для возврата всем действиям комбинаций клавиш, заданных по умолчанию, нажмите на кнопку «Сбросить горячие клавиши меню».

Горячие клавиши для элементов

В данной таблице указаны горячие клавиши, связанные с элементами текущего контейнера. Они задаются в диалоге редактирования элемента на складке Дополнительно. Для редактирования комбинации клавиш элемента щёлкните дважды на соответствующей строке. Будет открыт диалог редактирования элемента.


Псевдонимы

Псевдонимы для паролей

Если вы используете системы «единого входа», которые позволяют использовать один и тот же пароль для различных машин/серверов/приложений, то можно настроить несколько элементов Password Safe таким образом, чтобы изменение пароля в одном из них автоматически отражалось в остальных. Связывание элементов таким образом производится с помощью псевдонимов. Этот раздел описывает порядок определения и использования псевдонимов.

Краткое описание

Основная идея состоит в том, чтобы пароль одного элемента мог быть ссылкой на пароль другого элемента. Элемент, на который ссылаются называется исходным, а ссылающиеся на него именуются псевдонимами. Если элемент является псевдонимом для другого, его пароль совпадает с исходным. Так, при копировании в буфер обмен пароля псевдонима, туда будет помещён пароль исходного элемента. Изменение пароля исходного элемента немедленно отражается на связанных с ним псевдонимах. На первый взгляд это может показаться сложным, но, на самом деле, всё достаточно просто и понятно. Самая сложная часть — это определение псевдонимов.

Определение псевдонимов

Если в Password Safe пароль элемента записать определённым образом, он будет ссылался на пароль другого элемента. Для этого в поле пароля псевдонима нужно указать «имя» исходного элемента в квадратных скобках. Чаще всего под «именем» можно понимать заголовок элемента. Таким образом, если заголовок исходного элемента «Главный», то указание «[Главный]» (без кавычек) вместо пароля другого элемента делает его псевдонимом для элемента «Главный».

В общем случае, «имя» может содержать значения полей «группа», «заголовок» и «имя пользователя», разделённые двоеточием. Заметьте, что если заголовок уникален в данном контейнере, то другие поля являются необязательными. Аналогично, если пара «группа» и «заголовок» или «заголовок» и «имя пользователя» однозначно определяет элемент, то значение третьего поля можно не указывать.

В элементах контейнера Password Safe, только поле «заголовок» является обязательным для заполнения. Поля «группа» и «имя пользователя» необязательны если комбинация «группа/заголовок/имя пользователя» уникальна. Из описанного следует, что «пароль» для псевдонима имеет вид [g:t:u] (g – «группа», t – «заголовок», u – «имя пользователя»). При этом достаточно указать только ту информацию, по которой можно однозначно определить элемент. То есть, если в контейнере лишь один элемент с заголовком «t», то в качестве пароля псевдонима можно указать [t] (если указано только одно значение, то считается, что это заголовок, т. к. он является обязательным). В случае, если несколько элементов имеют одинаковый заголовок, будет выведено предупреждение, и вам потребуется указать дополнительную информацию об исходном элементе (группу и/или имя пользователя)! Допустимы следующие уникальные комбинации: [g:t:u], [g:t], [t:u] или [t]. Указание двоеточия без значения равносильно пустому полю, например, [g:t:] указывает на элемент с заголовком «t» в группе «g» без имени пользователя, а [:t:] равносильно элементу «t» без имени пользователя, находящемуся в корне дерева.

Ниже приведены поясняющие примеры.

Примеры

  1. Если заголовок исходного элемента «Сервер» и никакой другой элемент не имеет такого заголовка, то элемент, в поле пароль которого указано «[Сервер]», будет являться его псевдонимом.
  2. Если элемент «Сервер» присутствует в двух группах, например «Отдел A» и «Отдел B», тогда первый определяется сочетанием «[Отдел A:Сервер]». Заметьте, что нет необходимости писать имя пользователя, если указанной информации достаточно для однозначного определения элемента.
  3. Имя пользователя тоже может использоваться для различения похожих исходных элементов, например «[Сервер:Вася]» и «[Сервер:Маша]».
  4. Наконец, можно указать все три поля, например, «[Отдел A:Сервер:Вася]».

Отображение

В древовидном списке исходные элементы, на которые указывает хотя бы один псевдоним, помечены знаком зелёного треугольника вместо зелёного квадрата.

Псевдонимы помечены белыми треугольниками.


Формат текстового экспорта и импорта

Внимание! Экспорт важной информации из контейнера Password Safe в текстовый файл может привести к серьёзным последствиям, связанным с безопасностью. Эта операция приводит к созданию незащищённой копии указанных элементов. Простого удаления данной копии недостаточно, и требуется использование дополнительных утилит для гарантированного удаления данных. Экспорт важной информации позволяет обойти меры защиты, предоставляемые Password Safe.

Примечание. Некоторые параметры текстового экспорта и импорта были изменены в версии 3.06. Здесь описывается текущий формат.

Текстовый файл с экспортированными данными:

  • Начинается со строки с заголовками.
  • Для замены переносов строк в многострочных заметках и точки («.») в заголовках используется разделитель. По умолчанию это символ ‘»’ [Alt+0187], который может быть переопределён.

При импорте считается, что:

  • Первая строка содержит заголовки.
  • Для замены переносов строк в многострочных заметках и точки («.») в заголовках используется разделитель. По умолчанию это символ ‘»’ [Alt+0187], который может быть переопределён.

Строка с заголовками для полного экспорта содержит следующие поля, разделённые табуляцией (в скобках приведён перевод, который не пишется в файл экспорта):

  • Group/Title (группа/заголовок)
  • Username (имя пользователя)
  • Password (пароль)
  • URL (ссылка)
  • Autotype (автонабор)
  • Created Time (время создания)
  • Password Modified Time (время изменения пароля)
  • Last Access Time (время последнего доступа)
  • Password Expiry Date (дата истечения пароля)
  • Password Expiry Interval (срок действия пароля)
  • Record Modified Time (время изменения записи)
  • Password Policy (политика создания паролей)
  • History (история)
  • Run Command (выполнить команду)
  • DCA (действие по двойному клику)
  • e-mail (электронная почта)
  • Protected (защита элемента)
  • Symbols (набор символов для создания пароля)
  • Notes (заметки)

С помощью расширенных настроек экспорта можно исключить ненужные поля из заголовка и экспортируемых записей. Расширенные настройки также позволяют выбрать подмножество элементов для экспорта.

Расширенные настройки экспорта в простой текст

При импорте из текстового файла строка с заголовками должна содержать имена столбцов, совпадающие с именами из указанного списка. Если какой-либо из заголовков повторяется, будут использованы данные из последнего столбца с повторяющимся именем. Если заголовок не совпадает ни с одним из указанных, данные из этого столбца игнорируются. Поля должны быть разделены определённым символом, который указывается в диалоге импорта.

Примечания:
  • При импорте данных в Password Safe должны присутствовать и содержать непустые значения поля «Group/Title» (заголовок) и «Password» (пароль). Это ограничение вызвано требованиями к содержанию элементов, созданных стандартным способом.
  • Порядок столбцов может быть любым. Соответствие полей определяется по заголовкам.

Формат данных

Имя столбца (поля) | Примечания
Group/Title (группа/заголовок) | Группы (если присутствуют) разделяются точками («.»). Поле «Title» (заголовок) не может быть пустым или содержать символ-разделитель.
Username (имя пользователя)
Password (пароль) | Не может быть пустым.
URL (ссылка)
Autotype (автонабор)
Created Time (время создания) | См. примечание 1
Password Modified Time (время изменения пароля) | См. примечание 1
Last Access Time (время последнего доступа) | См. примечание 1
Password Expiry Date (дата истечения пароля) | См. примечание 1
Password Expiry Interval (срок действия пароля) | См. примечание 1
Record Modified Time (время изменения записи) | См. примечание 1
Password Policy (политика создания паролей) | См. примечание 3
History (история) | См. примечание 2
Run Command (выполнить команду)
DCA (действие по двойному клику) | См. примечание 4
Shift+DCA (действие по Shift+двойной клик) | См. примечание 4
e-mail (электронная почта)
Protected (защита элемента)
Symbols (набор символов для создания пароля)
Notes (заметки)
  • Содержимое поля с заметками должно быть заключено в двойные кавычки ("например, так").
  • Заметки не должны содержать символ-разделитель, так как при импорте он будет преобразован в перенос строки.

Примечание 1.

Время может быть указано в одном из 7 форматов:

1. | гггг/ММ/дд чч:мм:сс | например, 2007/01/26 19:31:25
2. | ддд МММ дд чч:мм:сс гггг | например, Вск Окт 31 19:31:25 2010
3. | гггг-ММ-ддTчч:мм:сс | например, 2007-01-26T19:31:25
4. | гггг-ММ-ддTчч:мм:ссZ (только XML) | например, 2007-01-26T19:31:25Z
5. | гггг-ММ-ддTчч:мм:сс±чч:мм (только XML) | например, 2007-01-26T19:31:25+01:00
6. | 0 | оставить поле незаполненным
7. | now | Использовать время импорта

где:

гггг | Год в четырёхзначном виде. Значение от 1970 до 2038.
ММ | Месяц в двузначном виде: 01 = январь, 02 = февраль, и т. д.
дд | День месяца.
МММ | Краткое наименования месяца (язык сокращения для месяца зависит от текущей локали): Jan = January, Feb = February или Янв = январь, Фев = февраль и т. д.
ддд | Краткое наименование дня недели (язык сокращения для дня недели зависит от текущей локали): Mon = Monday, Tue = Tuesday, Вск = воскресенье, Пнд. = понедельник и т. д.
чч | Час в 24-часовом формате.
мм | Минуты в двузначном формате
сс | Секунды в двузначном формате

Примечание. Формат 2 является выводом ANSI C функции «asctime», а формат 3 соответствует стандарту ISO 8601.

Примечания: 2

История паролей состоит из заголовка, описывающего элементы истории и требуемого количества записей о старых паролях:

Заголовок истории паролей:

  • 1 шестнадцатеричная цифра — ведение истории паролей для данного элемента (0 = нет; 1 = да);
  • 2 шестнадцатеричные цифры — максимальное количество элементов истории для данного элемента;
  • 2 шестнадцатеричные цифры — количество сохранённых паролей в истории.

Элемент истории паролей:

  • 8 шестнадцатеричных цифр — время помещения пароля в историю;
  • 4 шестнадцатеричные цифры — длина пароля в данном элементе;
  • строка символов — пароль, сохранённый в истории.

Примечания: 3

Политика создания паролей экспортируется как текстовое поле «ffffnnnllluuudddsss» в шестнадцатеричном формате, например, «F000010004002005003». Это поле содержит 6 шестнадцатеричных чисел. Первое из них состоит из 4-х цифр, остальные — из 3-х.

расшифровка «ffffnnnllluuudddsss»:

  • ffff — 4 шестнадцатеричные цифры, являющиеся комбинацией флагов:
    • 0x8000 — использовать строчные буквы;
    • 0x4000 — использовать прописные буквы;
    • 0x2000 — использовать цифры;
    • 0x1000 — использовать символы;
    • 0x0800 — использовать только шестнадцатеричные (0–9,a–f) символы (если указан данный флаг, остальные не должны быть установлены);
    • 0x0400 — использовать удобочитаемые символы;
    • 0x0200 — создавать произносимые пароли;
    • 0x01FF — не используется.
  • nnn — 3 шестнадцатеричные цифры: длина пароля;
  • lll — 3 шестнадцатеричные цифры: минимальное количество строчных букв;
  • uuu — 3 шестнадцатеричные цифры: минимальное количество прописных букв;
  • ddd — 3 шестнадцатеричные цифры: минимальное количество цифр;
  • sss — 3 шестнадцатеричные цифры: минимальное количество символов.

Политика паролей «F000010004002005003» расшифровывается как:

  • F000 — использовать строчные и прописные буквы, цифры и символы;
  • 010 — минимальная длина пароля 16 символов (в десятичной системе счисления);
  • 004 — не менее 4 строчных букв;
  • 002 — не менее 2 прописных букв;
  • 005 — не менее 5 цифр;
  • 003 — не менее 3 символов.

Примечания: 4

Допустимы следующие значения для действия по двойному клику:

  • -1 — действие по умолчанию;
  • 0 — копировать пароль в буфер обмена;
  • 1 — просмотр/редактирование элемента;
  • 2 — автонабор;
  • 3 — перейти по ссылке;
  • 4 — копировать заметки в буфер обмена;
  • 5 — копировать имя пользователя в буфер;
  • 6 — копировать пароль в буфер обмена и свернуть;
  • 7 — перейти по ссылке и выполнить автонабор;
  • 8 — выполнить команду;
  • 9 — отправить письмо.


Настройки

Настройки Password Safe

Как и многие другие приложения, Password Safe позволяет настроить свой вид и поведение согласно предпочтениям пользователя. Некоторые приложения используют для этих целей реестр Windows. Предыдущие версии Password Safe тоже использовали реестр, но это приводило к ряду проблем:

  • Некоторые настройки связаны с обеспечением безопасности, и хранение их в доступных местах может привести к получению злоумышленником несанкционированного доступа к контейнеру (например, если он отключит блокировку контейнера по истечении указанного времени, а пользователь не заметит этого и уйдёт на обед).
  • Многие пользователи используют один и тот же контейнер Password Safe на разных машинах (запускают со съёмного диска или сетевого ресурса). В данном случае хранение в реестре затрудняет использование общих настроек.

Настройки в Password Safe имеют предопределённое «значение по умолчанию». Когда пользователь изменяет ту или иную настройку, её новое значение (отличное от значения по умолчанию) сохраняется.

Настройки в Password Safe делятся на «связанные с обеспечением безопасности» и «не связанные с обеспечением безопасности». Первые хранятся в контейнере и шифруются с помощью того же ключа, что и остальные данные.

Оставшиеся настройки хранятся в файле pwsafe.cfg. Файл имеет формат XML. Для каждого пользователя и машины создаются отдельные элементы, чтобы несколько пользователей могли использовать один и тот же файл на различных машинах.

По умолчанию pwsafe.cfg сохраняется в том же каталоге, что и pwsafe.exe. Но, если задана переменная окружения PWS_PREFSDIR, Password Safe будет использовать файл настроек, указанный в ней. Может пригодится если доступ к каталогу, в котором установлен pwsafe.exe ограничен (см. также описание параметра -g в разделе Параметры командной строки).

Таблица описывает настраиваемые параметры. Большинство из них задаются в диалоге, открываемом через пункт меню Управление→Настройки. Т. к. используется XML-формат, имена полей чувствительны к регистру. Настройки из файла «pwsafe.cfg» применяются ко всем открытым контейнерам. Настройки, сохраняемые в контейнере, применяются только к нему. В Windows Vista и Windows 7 файл «pwsafe.cfg» находится в каталоге «C:\Users\<имя_пользователя>\AppData\Local\PasswordSafe», а в Windows XP — в каталоге «C:\Documents and Settings\<имя_пользователя>\Application Data\PasswordSafe». Данные каталоги могут быть скрытыми, и для их отображения может потребоваться изменение настроек Проводника. Устаревшие настройки не перечислены.

Обратите внимание, что значения, совпадающие со «значением по умолчанию» не сохраняются.

Примечание. Не рекомендуется изменять файл настроек вручную, т. к. это может привести к непредвиденным результатам. Несмотря на то, что значения настроек проверяются при чтении, мы не можем гарантировать, что параметры, заданные вручную, не вызовут проблем.

Настройки с логическими значениями (true («1») [истина]/false («0») [ложь])

Настройка | Значение по умолчанию | Где хранится | Примечание
AlwaysOnTop | false | pwsafe.cfg | Отображать Password Safe поверх всех окон
ShowPWDefault | false | контейнер | Отображение пароля при добавлении и редактировании
ShowUsernameInTree | true | контейнер | Отображение имени пользователя в древовидном списке
ShowPasswordInTree | false | контейнер | Отображение пароля в древовидном списке (необходимо, чтобы имя пользователя тоже было отображено)
ShowNotesDefault | false | контейнер | Отображение заметок при добавлении и редактировании
ShowNotesAsToolTipsInViews | false | pwsafe.cfg | Отображать заметки во всплывающей подсказке (только первые 250 символов)
SortAscending | true | контейнер | Направление сортировки при просмотре в виде списка (по возрастанию или убыванию)
UseDefaultUser | false | контейнер | Использование имени пользователя по умолчанию
SaveImmediately | true | контейнер | Сохранять контейнер после вставки или редактирования
PWUseLowercase | true | контейнер | Политика создания паролей: использовать строчные буквы
PWUseUppercase | true | контейнер | Политика создания паролей: использовать прописные буквы
PWUseDigits | true | контейнер | Политика создания паролей: использовать цифры
PWUseSymbols | true | контейнер | Политика создания паролей: использовать символы
PWUseHexDigits | false | контейнер | Политика создания паролей: использовать только шестнадцатеричные цифры (всегда чётное количество)
PWUseEasyVision | false | контейнер | Политика создания паролей: использовать только легкоотличимые символы
PWMakePronounceable | false | контейнер | Политика создания паролей: создавать произносимые пароли
dontaskquestion | false | pwsafe.cfg | Не спрашивать подтверждения при копировании в буфер обмена
deletequestion | false | pwsafe.cfg | Не спрашивать подтверждения при удалении одного элемента
DatabaseClear | false | pwsafe.cfg | Блокировать (выгружать из памяти) контейнер при сворачивании
QuerySetDef | true | pwsafe.cfg | При создании нового элемента запрашивать установку имени пользователя по умолчанию
UseNewToolbar | true | pwsafe.cfg | Использовать «классическую» или «современную» панель инструментов
UseSystemTray | true | pwsafe.cfg | Отображать значок Password Safe в области уведомлений
LockOnWindowLock | true | pwsafe.cfg | Блокировать контейнер Password Safe при блокировке компьютера
EscExits | true | pwsafe.cfg | Использовать Esc для закрытия контейнера и выхода из Password Safe (если не используется значок в области уведомлений)
HotKeyEnabled | false | pwsafe.cfg | True [истина], если назначена горячая клавиша для вызова Password Safe
MRUOnFileMenu | true | pwsafe.cfg | Отображать недавно использованные контейнеры в меню Файл, а не в подменю
MaintainDateTimeStamps | false | контейнер | Записывать дату последнего обращения к элементу, если контейнер открыт в режиме «чтение/запись»
SavePasswordHistory | false | контейнер | Сохранять предыдущее значение при изменении пароля элемента
BackupBeforeEverySave | true | pwsafe.cfg | Создавать резервные копии при сохранении контейнера
PreExpiryWarn | false | pwsafe.cfg | При открытии контейнера предупреждать об истёкших или истекающих паролях
ExplorerTypeTree | false | pwsafe.cfg | Отображать группы вверху дерева
ListViewGridLines | false | pwsafe.cfg | Отображать сетку списка
MinimizeOnAutotype | true | pwsafe.cfg | Сворачивать окно Password Safe при выполнении автонабора В зависимости от настроек, при сворачивании программы возможна блокировка контейнера
ShowToolbar | true | pwsafe.cfg | Отображать панель инструментов
ShowDragbar | true | pwsafe.cfg | Отображать «панель Dragbar»
ShowFindToolBarOnOpen | true | pwsafe.cfg | При запуске Password Safe отображать панель поиска Определяется состоянием панели поиска при последнем закрытии Password Safe
DefaultOpenRO | false | pwsafe.cfg | При открытии контейнера по умолчанию устанавливать флажок «только для чтения»
MultipleInstances | true | pwsafe.cfg | Разрешить одновременный запуск нескольких копий Password Safe Для применения требуется перезапуск всех копий Password Safe
ClearClipboardOnMinimize | true | pwsafe.cfg | Очищать буфер обмена при сворачивании Password Safe
ClearClipboardOnExit | true | pwsafe.cfg | Очищать буфер обмена при завершении работы Password Safe
NotesWordWrap | true | pwsafe.cfg | При редактировании переносить заметки по словам
LockDBOnIdleTimeout | true | контейнер | Блокировать контейнер по истечении указанного времени с момента выполнения последнего действия с программой. Время указывается в параметре «IdleTimeout»
HighlightChanges | true | pwsafe.cfg | Подсветить изменённые элементы
HideSystemTray | false | pwsafe.cfg | Скрывать значок Password Safe в области уведомлений. Используется только если назначена горячая клавиша для вызова Password Safe
UsePrimarySelectionForClipboard | false | pwsafe.cfg | Использовать основной буфер обмена (только в Linux)
CopyPasswordWhenBrowseToURL | false | контейнер | При переходе по ссылке копировать пароль в буфер обмена ---------

Настройки с числовыми значениями

Настройка | Значение по умолчанию | Где хранится | Мин. | Макс. | Примечание
column1width | не задано | pwsafe.cfg | не задано | не задано | Ширина первого столбца при прошлом выходе из Password Safe
column2width | не задано | pwsafe.cfg | не задано | не задано | Ширина второго столбца при прошлом выходе из Password Safe
column3width | не задано | pwsafe.cfg | не задано | не задано | Ширина третьего столбца при прошлом выходе из Password Safe
column4width | не задано | pwsafe.cfg | не задано | не задано | Ширина четвёртого столбца при прошлом выходе из Password Safe
sortedcolumn | 0 | pwsafe.cfg | 0 | 15 | Столбец для сортировки списка
PWDefaultLength | 12 | контейнер | 4 | 1024 | Длина пароля по умолчанию
maxmruitems | 4 | pwsafe.cfg | 0 | 20 | Количество запоминаемых контейнеров, отображаемых в меню «Файл»
IdleTimeout | 5 | контейнер | 1 | 120 | Время простоя, по истечении которого Password Safe будет блокироваться (если включено)
DoubleClickAction | Копирование пароля | pwsafe.cfg | не задано | не задано | Для получения дополнительной информации см. Перечень значений для действия по двойному клику
HotKey | none | pwsafe.cfg | не задано | не задано | Горячая клавиша (Хранится как десятичное целое: в младшем слове содержится виртуальный код символа, в старшем — флаги CHotKeyCtrl [Microsoft Foundation Class])
MaxREItems | 25 | pwsafe.cfg | 0 | 25 | Количество недавно использованных элементов, отображаемых в списке значка в области уведомлений
TreeDisplayStatusAtOpen | AllCollapsed | контейнер | не задано | не задано | Возможные значения: «AllCollapsed» [полностью свёрнуто], «AllExpanded» [полностью развёрнуто] или «AsPerLastSave» [как в прошлый раз]
NumPWHistoryDefault | 3 | контейнер | 0 | 255 | Количество паролей, сохраняемых в истории
BackupSuffix | 0 | pwsafe.cfg | не задано | не задано | Возможные значения: «None» [нет], «datetime» [дата и время] или «incremental number» [по счётчику]
BackupMaxIncremented | 1 | pwsafe.cfg | 1 | 999 | Используется только если BackupSuffix имеет значение incremental number
PreExpiryWarnDays | 1 | pwsafe.cfg | 1 | 30 | Предупреждение о сроке истечения паролей
ClosedTrayIconColour | 0 | pwsafe.cfg | 0 | 0 | Цвет значка в области уведомлений для заблокированного контейнера Password Safe. 0 — Чёрный, 1 — Голубой, 2 — Белый, 3 — Жёлтый
PWDigitMinLength | 0 | контейнер | 0 | 1024 | Минимальное количество цифр в создаваемом пароле
PWLowercaseMinLength | 0 | контейнер | 0 | 1024 | Минимальное количество строчных букв в создаваемом пароле
PWUppercaseMinLength | 0 | контейнер | 0 | 1024 | Минимальное количество прописных букв в создаваемом пароле
PWSymbolMinLength | 0 | контейнер | 0 | 1024 | Минимальное количество символов в создаваемом пароле
OptShortcutColumnWidth | 92 | pwsafe.cfg | 10 | 512 | Размеры столбцов на вкладке Управление→Настройки→Комбинации клавиш
ShiftDoubleClickAction | Копирование пароля | pwsafe.cfg | не задано | не задано | Для получения дополнительной информации см. Перечень значений для действия по двойному клику

Настройки с текстовыми значениями

Настройка | Значение по умолчанию | Где хранится | Примечание
currentbackup | <не задано> | pwsafe.cfg | Путь и имя последней резервной копии
currentfile | <не задано> | pwsafe.cfg | Текущий (последний) открытый файл
lastview | tree | pwsafe.cfg | Последний выбранный стиль отображения: «tree» (дерево) или «list» (список)
DefaultUsername | <не задано> | контейнер | Имя пользователя по умолчанию
treefont | <не задано> | pwsafe.cfg | Шрифт, используемый в древовидном списке
PasswordFont | <не задано> | pwsafe.cfg | Шрифт, используемый для отображения пароля
BackupPrefixValue | <не задано> | pwsafe.cfg | По умолчанию приставка для имён резервных копий контейнеров совпадает с именем контейнера. Здесь можно переопределить её значение.
BackupDir | <не задано> | pwsafe.cfg | По умолчанию резервные копии создаются в том же каталоге, где находится открытый в настоящий момент контейнер. Здесь можно переопределить её значение.
AltBrowser | <не задано> | pwsafe.cfg | Полный путь к альтернативному браузеру
ListColumns | <не задано> | pwsafe.cfg | Порядок столбцов при отображении в виде списка. Через запятую перечислены используемые внутри программы номера столбцов.
ColumnWidths | <не задано> | pwsafe.cfg | Ширина столбцов при отображении в виде списка
DefaultAutotypeString | \u\t\p\t\n | контейнер | Строка автонабора по умолчанию. Данное значение может быть переопределено в свойствах элемента.
AltBrowserCmdLineParms | <не задано> | pwsafe.cfg | Параметры командной строки для альтернативного браузера
MainToolBarButtons | <не задано> | pwsafe.cfg | Перечень и порядок кнопок, отображаемых на панели инструментов. В качестве разделителя используется символ «~»
TreeListSampleText | «AaBbYyZzАаБбЖжЯя 0O1lIL» | pwsafe.cfg | Текст образца для шрифта, используемого в древовидном списке
PswdSampleText | «AaBbYyZzАаБбЖжЯя 0O1lIL» | pwsafe.cfg | Текст образца для шрифта, используемого при отображении паролей
VKSampleText | «AaBbYyZzАаБбЖжЯя 0O1lIL» | pwsafe.cfg | Текст образца для шрифта, используемого в экранной клавиатуре
VKeyboardFontName | <не задано> | pwsafe.cfg | Имя шрифта с поддержкой Unicode, используемого для отображения символов на экранной клавиатуре. Используется как для латинских, так и для всех остальных символов
LastUsedKeyboard | <не задано> | pwsafe.cfg | Идентификатор раскладки экранной клавиатуры, использованной в последний раз
AltNotesEditor | <не задано> | pwsafe.cfg | Полный путь к внешнему редактору для изменения заметок.
LanguageFile | <не задано> | pwsafe.cfg | Идентификатор используемого языкового файла. Имеет вид «LL» или «LL_CC», где LL — двухсимвольный код языка по ISO 639-1, например, «EN», «FR», «DE», «RU», ... (см. http://www.loc.gov/standards/iso639-2/), а CC — двухсимвольный код страны по ISO 3166-1, например, «US», «GB», «FR», «CA», ... (см. http://www.iso.org/iso/en/prods-services/iso3166ma/index.html)
DefaultSymbols | <не задано> | контейнер | Набор символов по умолчанию для создания пароля. Примечание. Данное значение может быть переопределено в свойствах элемента.


Выполнение команд

В поле «Выполнить» можно указать команду, выполняемую при выборе действия «Выполнить команду». Можно указать любую команду, которая может быть выполнена в ОС Windows через меню «Пуск»→«Выполнить».

Также, Password Safe может передать в параметры команды имя пользователя, пароль и некоторые другие данные, описанные ниже. Это позволяет производить некоторые сложные действия, например, запустить программу удалённого доступа (например, PuTTY) и передать ей имя пользователя и пароль, связанные с элементом.

«Переменные» заменяются соответствующими значениями перед выполнением команды. Символ доллара («$») используется для указания переменных.

  • Имена переменных имеют вид «$name» и являются регистрозависимыми. Имя переменной должно начинаться с буквы, в последующих символах имени можно использовать буквы и цифры. Имя переменной заканчивается перед символом отличным от буквы и цифры (например, пробел) или концом команды.
    • В случае, если требуется добавить букву или цифру сразу после значения переменной, заключите имя переменной в фигурные скобки, например, «${varname}строка».
    • Для использования знака «$» как обычного символа в строке (чтобы он не указывал на имя переменной), экранируйте его символом «\». Например, «\$text» рассматривается как «$text», а не как переменная с именем «text».
    • Для того чтобы вставить «\» перед символом «$», экранируйте его с помощью символа «\». «\\$name» рассматривается как «\$name» в конечном тексте, при этом «$name» считается переменной. Символ «\» не нужно экранировать, если он не идёт перед символом «$».
    • После переменной может указываться числовое значение в квадратных скобках, называемое «индексом». Значение индекса «n» может предваряться символом «+» или «-», например, [-2], [2] или [+2]. Password Safe считает нулевой индекс соответствующим значению всего поля.
  • В настоящий момент распознаются следующие переменные:
    • Связанные с приложением:
      • appdir Каталог, содержащий исполняемый файл Password Safe (pwsafe.exe). См. примечания 1 и 2.
    • Связанные с контейнером:
      • dbdir | Каталог, содержащий текущий контейнер. См. примечания 1 и 2.
fulldb | Полный путь, имя файла и расширение текущего контейнера. См. примечание 2.
dbname | Имя файла текущего контейнера.
dbextn | Расширение файла текущего контейнера.
    • Связанные с текущим элементом:
      • g или group | Группа (полный путь до корня, разделённый точками).
G или GROUP | Имя группы, содержащей текущий элемент.
t или title | Заголовок
u или user | Имя пользователя
p или password | Пароль
e или email | e-mail (электронная почта)
a или autotype | Автонабор. См. примечание 5.
url | Ссылка
n или n[0] | Содержание всего поля заметок (также: notes или notes[0]). См. примечание 3.
n[i] или notes[i] | i-я строка заметок, считая с начала: i=1 — первая строка, i=2 — вторая и т. д. См. примечание 4.
n[-i] или notes[-i] | i-я строка заметок, считая с конца: i=1 — последняя строка, i=2 — предпоследняя и т. д. См. примечание 4.
      Заметки
      1 | Имена каталогов (appdir или dbdir) не содержат конечного обратного слэша («\»). Не забудьте добавить его, если это требуется в параметрах программы.
      2 | В значении переменной (включая имена каталогов и полные пути) могут присутствовать пробелы. Для корректного выполнения команды может потребовать заключение переменной в кавычки.
      3 | Если поле заметок состоит из нескольких строк, значение переменной также будет содержать имеющиеся там символы возврата каретки (CR) и переноса строки (LF). Это может привести к ситуации когда CR и/или LF будут расценены как нажатие клавиши «Enter».
      4 | При указании одиночных строк заметок конечные символы CR и/или LF отбрасываются.
      5 Если в команде присутствует переменная автонабора, операция автонабора будет выполнена, как только окно приложения станет активным. При этом переменная и её значение будут убраны из строки параметров. Данная переменная может быть написана в любом месте поля «Выполнить», так как она указывает, что должен сделать Password Safe после выполнения команды. В отличие от других переменных, она может принимать дополнительный параметр для изменения значения по умолчанию. Используется следующий формат (в указанных примерах «$a» можно заменить на «$autotype»):
      $a | Использовать значение из текущего элемента.
${a} | Использовать значение из текущего элемента (фигурные скобки нужны, если за «$a» следует текст).
$a(значение) | Использовать строку автонабора, указанную в круглых скобках.
${a}(значение) | Использовать строку автонабора, указанную в круглых скобках.

      Примечание. Не забудьте окружить строки кавычками, если это требуется. Например, если путь к контейнеру содержит пробелы, путь к текстовому файлу в данном каталоге следует писать так (с кавычками):

      '$dbdir\\$dbname.txt'

      Обратите внимание, что для того, чтобы «$dbname» было распознано как переменная, обратный слэш экранирован.

      В ОС Windows также можно подставлять переменные окружения (как обычно, имя переменной окружается символами «%», например, %variable_name%). Пример: «%windir%\notepad.exe» преобразуется в «C:\Windows\notepad.exe» (зависит от каталога установки Windows). Текущие значения переменных можно определить, запустив «cmd.exe» и выполнив в консоли команду «set» без параметров. Имена неопознанных переменных окружения остаются без изменений. Например, "%xyz%\notepad.exe" останется равным "%xyz%\notepad.exe", если переменная окружения «xyz» не определена. Примечание. В ОС Windows переменные окружения регистронезависимы.

Примеры

  • Для подключения к myHost с именем пользователя и пароля из текущего элемента через PuTTY, нужно указать в поле «Выполнить» следующее значение:
    "C:\Program Files\PuTTY\putty.exe" -ssh ${u}@myHost 22 -pw $p
  • Открытие указанного контейнера в новом экземпляре Password Safe (спасибо Дейву (Dave) за пример):
     ${autotype}(\p\n)"${appdir}\pwsafe.exe" \UNC\path\to\database.psafe3
    • Чтобы данный пример заработал, убедитесь, что разрешён запуск нескольких экземпляров на вкладке «Управление→Настройки→Система».
    • Также может оказаться удобным изменить «Действие по двойному клику» для этого элемента на «Выполнить команду».


Комбинации клавиш

Комбинации клавиш/горячие клавиши

Ниже описываются особенности определения и использования горячих клавиш в Password Safe.

Указанные комбинации клавиш проверялись на 102-клавишной клавиатуре с расширенной английской раскладкой. Стандартные комбинации клавиш должны работать на любой другой клавиатуре с латинскими символами. Некоторые комбинации клавиш могут отличаться, например, на клавиатуре с английской раскладкой символ «#» находится на клавише с тильдой «~», а на американской раскладке он находится на той же клавише, что и символ 3 (для вызова используется Shift+3). Просмотрите таблицу и, при необходимости, адаптируйте её для вашей клавиатуры (в любой момент вы можете проверить, работает ли та или иная комбинация).

В зависимости от языка, некоторые комбинации с клавишей Alt могут быть зарезервированы. Это буквы, используемые для вызова элементов главного меню. При нажатии клавиши Alt в главном окне, соответствующие буквы в именах пунктов меню будут подчёркнуты. Для Английского языка это Alt+F (File), Alt+E (Edit), Alt+V (View), Alt+M (Manage) и Alt+H (Help). Для прочих локализаций нужно свериться с тем, что будет подчёркнуто в главном меню. Например, в русской локализации пункт меню «File» заменяется на «Файл», поэтому вместо Alt+F будет зарезервирована комбинация Alt+Ф.

Клавиша Enter также зарезервирована, так как она используется для задания горячих клавиш на вкладке Управление→Настройки→Комбинации клавиш. Поэтому её невозможно переназначить. Также, при отображении элементов в виде дерева, действие «Развернуть/свернуть группу» вызывается по клавише Enter. Несмотря на то, что на данное действие можно было бы назначить другую комбинацию клавиш, сворачивание/разворачивание ветви всё равно происходило бы и по нажатию клавиши Enter, так как это системная комбинация для древовидного списка. По этой причине комбинацию клавиш для данного действия нельзя задать на вкладке «Комбинации клавиш».

Клавиша Esc также зарезервирована, так как она используется для скрытия панели поиска и сворачивания Password Safe в значок (или выхода из приложения, если использование значка в области уведомлений отключено в настройках). Кроме того, нажатие на Esc равносильно нажатию кнопки «Отмена» в диалогах.

По умолчанию, горячая клавиша для просмотра в режиме «только чтение» совпадает с клавишей редактирования в обычном режиме. Данные сочетания нельзя задать по отдельности. Аналогично, «Удалить элемент» совпадает с «Удалить группу», а «Переименовать элемент» совпадает с «Переименовать группу». Поэтому, соответствующие действия на вкладке «Комбинации клавиш» названы просто «Удалить» и «Переименовать».

Некоторые комбинации клавиш зарезервированы ОС Windows, например, Ctrl+Alt+Delete, Tab, Shift+Tab, Alt+Tab, Alt+Shift+Tab и др.

Нестандартные клавиши не поддерживаются (они присутствуют на клавиатуре с раскладкой Kanji).

Password Safe не различает правые и левые клавиши Ctrl, Alt и Shift. Поэтому, на некоторых клавиатурах часть комбинаций клавиш может быть недоступна. Например, символ евро на 102-клавишной английской расширенной клавиатуре набирается с помощью правого Alt (Alt Gr) и кнопки с цифрой 4. Но нажатие данной комбинации будет воспринято как Ctrl+Alt+4. Это связано с особенностями обработки комбинаций горячих клавиш в ОС Windows и не является ограничением, внесённым Password Safe.

Примечание. Использование нестандартных клавиш может привести к тому, что соответствующие горячие клавиши будут недоступны на клавиатурах, где данные символы отсутствуют. Поэтому, рекомендуется использовать только перечисленные ниже сочетания.

Описание заголовков столбцов:

Заголовок | Значение
K | Только указанная клавиша
A+K | Клавиша нажимается вместе с Alt
C+K | Клавиша нажимается вместе с Ctrl
S+K | Клавиша нажимается вместе с Shift
A+S+K | Клавиша нажимается вместе с Alt и Shift
C+S+K | Клавиша нажимается вместе с Ctrl и Shift
A+C+K | Клавиша нажимается вместе с Alt и Ctrl
A+C+S+K | Клавиша нажимается вместе с Alt, Ctrl и Shift

Имя клавиши | K | A+K | C+K | S+K | A+S+K | C+S+K | A+C+K | A+C+S+K
Забой (Backspace) | Y | N | Y | Y | N | Y | Y | Y
Табуляция (Tab) | N | N | Y | N | N | Y | Y | Y
Enter | R (1) | N | Y | N | N | Y | Y | Y
Escape (Esc) | N | N | N | N | N | N | N | N
Пробел | Y | N | Y | Y | N | Y | Y | Y
Page Up (PgUp) | Y | Y | N | Y | Y | N | N | N
Page Down (PgDn) | Y | Y | N | Y | Y | N | N | N
End | Y | Y | Y | Y | Y | Y | Y | Y
Home | Y | Y | Y | Y | Y | Y | Y | Y
Стрелка влево | Y | Y | Y | Y | Y | Y | Y | Y
Стрелка вверх | Y | Y | Y | Y | Y | Y | Y | Y
Стрелка вправо | Y | Y | Y | Y | Y | Y | Y | Y
Стрелка вниз | Y | Y | Y | Y | Y | Y | Y | Y
Print Screen (PrtSc) | N | N | N | N | N | N | N | N
Insert (Ins) | Y | Y | Y | Y | Y | Y | Y | Y
Удалить | Y | N | Y | Y | N | Y | N | Y
0–9 | Y | Y | Y | Y | Y | Y | Y | Y
A-Z | Y | Y | R (2) | Y | Y | Y | Y | Y
Серые 0–9 (на цифровой клавиатуре) | Y | Y | Y | N | Y | N | Y | N
Серый «*» (на цифровой клавиатуре) | Y | Y | Y | Y | Y | Y | Y | Y
Серый «+» (на цифровой клавиатуре) | Y | Y | Y | Y | Y | Y | Y | Y
Серый «-» (на цифровой клавиатуре) | Y | Y | Y | Y | Y | Y | Y | Y
Серая «.» (на цифровой клавиатуре) | Y | Y | Y | N | N | N | N | N
Серый «/» (на цифровой клавиатуре) | Y | Y | Y | Y | Y | Y | Y | Y
F1 | R (3) | Y | Y | Y | Y | Y | Y | Y
F2 | Y | Y | Y | Y | Y | Y | Y | Y
F3 | Y | Y | Y | Y | Y | Y | Y | Y
F4 | Y | R (2) | Y | Y | Y | Y | Y | Y
F5 | Y | Y | Y | Y | Y | Y | Y | Y
F6 | Y | Y | Y | Y | Y | Y | Y | Y
F7 | Y | Y | Y | Y | Y | Y | Y | Y
F8 | Y | Y | Y | Y | Y | Y | Y | Y
F9 | Y | Y | Y | Y | Y | Y | Y | Y
F10 | Y | Y | Y | Y | Y | Y | Y | Y
F11 | Y | Y | Y | Y | Y | Y | Y | Y
F12 | Y | Y | Y | Y | Y | Y | Y | Y
Num Lock (NumLk) | Y | Y | N | Y | N | Y | Y | Y
Scroll Lock (Scroll) | Y | Y | Y | Y | Y | Y | Y | Y
; : (4) | Y | Y | Y | Y | Y | Y | Y | Y
+ = | Y | Y | Y | Y | Y | Y | Y | Y
, < | Y | Y | Y | Y | Y | Y | Y | Y
- _ | Y | Y | Y | Y | Y | Y | Y | Y
. > | Y | Y | Y | Y | Y | Y | Y | Y
/ ? (4) | Y | Y | Y | Y | Y | Y | Y | Y
# ~ (4) | Y | Y | Y | Y | Y | Y | Y | Y
[ { (4) | Y | Y | Y | Y | Y | Y | Y | Y
\ | (4) | Y | Y | Y | Y | Y | Y | Y | Y
] } (4) | Y | Y | Y | Y | Y | Y | Y | Y
' @ (4) | Y | Y | Y | Y | Y | Y | Y | Y
` ¬ (4) | Y | Y | Y | Y | Y | Y | Y | Y

Примечания:

  1. Так как клавиша Enter используется для задания горячих клавиш, её нельзя назначить на то или иное действие.
  2. Ctrl+Q и Alt+F4 зарезервированы для закрытия приложения.
  3. F1 зарезервировано для вызова справки.
  4. Может зависеть от клавиатуры.


Значки элементов

Ниже приведены значки, используемые для отображения типов элементов в древовидном и простом списках. Примечание. В древовидном списке значки отображаются всегда. В простом списке столбец со значками может быть добавлен только как первый столбец.

Группа [только в древовидном списке]

Пустая группа [только в древовидном списке]

Обычный элемент

Обычный элемент с псевдонимами

Обычный элемент с ярлыками

Псевдоним

Ярлык

Кроме того, у обычных элементов может быть задана дата истечения пароля. Если для таких элементов настроено предупреждение (например, за 5 дней до истечения), их значки станут наполовину пурпурными при наступлении срока предупреждения.

Обычный элемент — срок действия пароля истечёт в течение указанного в предупреждении времени.

Обычный элемент с псевдонимами — срок действия пароля истечёт в течение указанного в предупреждении времени.

Обычный элемент с ярлыками — срок действия пароля истечёт в течение указанного в предупреждении времени.

У элементов с истёкшим паролем весь значок становится пурпурным.

Обычный элемент — срок действия пароля истёк.

Обычный элемент с псевдонимам — срок действия пароля истёк.

Обычный элемент с ярлыками — срок действия пароля истёк.


Благодарности

Использованные программы

Выражаем благодарность Брюсу Шнайеру (Bruce Schneier) за создание алгоритма шифрования Twofish и публикацию Password Safe, а также SourceForge.net за размещение проекта и поддержку сообщества Open Source.
С версии 3.29 для работы с файлом настроек Password Safe использует pugixml. Код pugixml распространяется под лицензии MIT.
Начиная с версии 3.12, Password Safe может создавать произносимые пароли с помощью алгоритма Тома ван Флека (Tom Van Vleck), Морри Гассера (Morrie Gasser), и Дэна Эдвардса (Dan Edwards).

Ниже указаны ссылки на различные страницы сайта SourceForge, связанные с проектом Password Safe:

  • Домашняя страница Password Safe: информация и новости о Password Safe, анонсы новых версий и текущий статус проекта. Домашняя страница поддерживается Брэдом Ченсом (Brad Chance). Спасибо, Брэд!
  • Коллектив разработчиков: лишь некоторые из тех, кто помог при разработке Password Safe, и поддерживает его развитие.
  • Форум Password Safe: форум для вопросов, технической поддержки и разрешения проблем.
  • Новости Password Safe: RSS-каналы о данном проекте.
  • Малоактивный (около одного сообщения в месяц), не содержащий спама, список рассылки Password Safe с анонсами новых версий.


Расширенные условия отбора

В мастере при сравнении, слиянии, синхронизации и экспорте в простой текст или XML

Мастер: расширенные настройки

Чтобы задать ограничения сравнения, слияния, синхронизации или экспорта, вы можете установить флажок «Расширенные условия отбора» на первой странице мастера. Таким образом вы также сможете ограничить список полей для сравнения, синхронизации или экспорта.

Для каждого вида действий указанные условия запоминаются на время сессии и не зависят друг от друга. Если вы закроете Password Safe и перезапустите его, ограничения будут сняты, а списки полей будут иметь значения по умолчанию, характерные для данных функций.

В случае, если вы уже задали какие-либо условия, или ограничили список полей, но не хотите использовать их в данный момент, нажмите кнопку «Назад» и снимите флажок «Расширенные условия отбора». Указанные «Расширенные условия отбора» сохранятся, но не будут использованы.

Для возврата ограничений на условия по умолчанию нажмите кнопку «Сбросить». Сброс условий в одном из мастеров (например, для сравнения) не приведёт к сбросу указанных значений для остальных (слияния, синхронизации, экспорта).

С помощью кнопки на панели поиска

Поиск: расширенные настройки

Нажав на панели поиска кнопку «Расширенные», вы сможете задать условия, ограничивающие поиск. Вы также можете ограничить список полей для рассмотрения.

Указанные условия поиска запоминаются на время сессии и не зависят от описанных выше. Если вы закроете Password Safe и перезапустите его, ограничения будут сняты, а списки полей будут иметь значения по умолчанию, характерные для поиска.

В случае, если вы уже задали какие-либо условия, или ограничили список полей, но не хотите использовать их в данный момент, нажмите кнопку «Отмена» или «ОК», а затем кнопку «Расширенные» на панели поиска (чтобы она перестала быть утопленной). Указанные «Расширенные условия отбора» сохранятся, но не будут использованы.

Для возврата ограничений поиска на условия по умолчанию нажмите кнопку «Сбросить». Сброс условий поиска не приведёт к сбросу указанных ограничений для остальных мастеров.

Синхронизация элементов при просмотре результатов сравнения контейнеров

Если при сравнении окажется, что данные в контейнерах не совпадают, будет выведено окно с результатами. Нажатие правой кнопкой мыши на букве «Y» приводит к отображению контекстного меню. Для элементов из текущего контейнера единственное доступное действие это редактирование данного элемента (или просмотр, если контейнер открыт в режиме «только чтение»). Для элементов из сравниваемого контейнера доступны просмотр, копирование в исходный контейнер и синхронизация.

Если выбрано действие «Синхронизировать», отображается диалог, позволяющий указать поля для синхронизации.

Для каждого вида действий указанные условия запоминаются на время сессии и не зависят друг от друга. Если вы закроете Password Safe и перезапустите его, списки полей будут содержать значения по умолчанию, характерные для данных функций.


Результаты сравнения

Окно результатов сравнения

Если при сравнении контейнеров обнаруживаются отличия, выводится окно с результатами. Примечание. Так как сравниваются лишь заданные пользователем поля, два отличающихся контейнера могут быть признаны одинаковыми, если они отличаются лишь в полях, исключённых из сравнения. По умолчанию все поля участвуют в сравнении. Если вы укажете свой список полей для сравнения, он будет использоваться только в текущем экземпляре Password Safe. То же правило применимо для всех мастеров, но соответствующие списки независимы:

  • Сравнение
  • Экспорт в простой текст (весь контейнер или один элемент)
  • Экспорт в XML (весь контейнер или один элемент)
  • Слияние
  • Синхронизация

Для отличающихся элементов списка возможны следующие действия:

  • Щелчок правой кнопкой мыши на элементе из текущего контейнера (первый столбец):
    • Редактирование элемента, если контейнер открыт в режиме «чтение/запись», и элемент не является защищённым.
    • Просмотр элемента, если контейнер открыт в режиме «только чтение», или элемент является защищённым.
  • Щелчок правой кнопкой мыши на элементе из сравниваемого контейнера (второй столбец):
    • Просмотр элемента (сравниваемый контейнер всегда открывается в режиме «только чтение», т. к. для него недоступна отмена последнего действия).
    • Копирование элемента в текущий контейнер, если он открыт в режиме «чтение/запись», и существующий элемент не является защищённым.
    • Синхронизация элемента в текущем контейнере с выбранным, если текущий контейнер открыт в режиме «чтение/запись», и существующий элемент не является защищённым.
    • Если различающийся элемент присутствует в обоих контейнерах, доступен пункт меню «Сравнить элементы...». При выборе данного пункта отображается список всех полей этих элементов с указанием отличающихся.

Кроме того, вы можете выделить несколько элементов из сравниваемого контейнера. Для пометки элемента щёлкните левой кнопкой мыши во втором столбце (для пометки второго и последующих элементов удерживайте Ctrl). По окончании выбора вы можете скопировать отмеченный элементы («Копировать все элементы в исходный») или синхронизировать их с соответствующими экземплярами из текущего контейнера («Синхронизировать все элементы»). Примечание. Синхронизация доступна только если все выбранные элементы присутствуют в текущем контейнере. Защищённый элемент не может быть выделен вместе с остальными, т. к. он не может быть изменён. Как и в основном списке, защищённый элемент помечается символом «#».


Именованные политики создания паролей

Начиная с версии 3.28, PasswordSafe позволяет работать с именованными политиками. Создание и управление политиками производится через меню Управление→Политики создания паролей... Политики привязаны к контейнеру и хранятся в заголовке контейнера. Данный пункт меню также заменяет настройки политики по умолчанию, которые раньше задавались через Управление→Настройки.

Окно управления политиками создания паролей

Здесь вы можете редактировать политику по умолчания для текущего контейнера, а также создавать, редактировать и удалять «именованные» политики. Политика, которая используется хотя бы одним элементом не может быть удалена. После выбора политики её параметры отображаются внизу. Для получения списка элементов, использующих данную политику нажмите кнопку «Список» (для возврата к списку параметров нажмите кнопку «Информация»). Чтобы отредактировать/просмотреть ссылающийся элемент, щёлкните по нему дважды.

Изменение политики по умолчанию

Чтобы отредактировать параметры политики по умолчанию, выберите ёё в списке и нажмите кнопку «Изменить». Будет отображён следующий диалог:

Редактирование политики по умолчанию

Добавление новой именованной политики

Для добавления новой именованной политики нажмите кнопку «Создать». Будет отображён показанный ниже диалог. Начальные значения параметров берутся из политики по умолчанию для текущего контейнера. К параметрам применяются те же правила согласования, что и для политики по умолчанию. Кроме того вам нужно задать имя политики (оно должно быть уникально в текущем контейнере). Примечание. Имя политики должно быть не больше 255 символов.

Диалог добавления новой именованной политики

Редактирование существующей именованной политики

Для редактирования параметров выберите требуемую именованную политику и нажмите кнопку «Изменить». Будет отображён показанный ниже диалог. Имя существующей политики не может быть изменено.

Диалог редактирования именованной политики

Редактирование/просмотр элемента и функция создания паролей

При редактировании элемента и создании пароля через пункт меню «Управление→Создать пароль» можно использовать именованные политики создании пароля. Именованные политики, не связанные с элементами, могут быть использованы при генерации паролей.

Проверка политики создания паролей

Вы можете выбрать политику по умолчанию или любую другую именованную политику, а затем нажать кнопку «Создать». Полученный пароль можно скопировать в буфер обмена.

Контейнеры открытые только для чтения

Если контейнер открыт в режиме «только чтение», добавление, удаление и редактирование политик создания паролей невозможно. Просмотр параметров существующих политик доступен в любом режиме. Любые изменения, произведённые во время просмотра, не будут сохранены.

Отмена/повтор изменений

Для отмены/повтора изменений в политиках создания паролей вы можете использовать кнопки «Вернуть» и «Повторить» соответственно (или комбинации клавиш Ctrl+Z и Ctrl+Y [или их эквиваленты, определённые на вкладке Управление→Настройки→Комбинации клавиш]). Если какое-либо действие было отменено, вы можете вернуть его, нажав кнопку «Повторить» (если после него не было совершено других действий). Изменения сохраняются в контейнер только после нажатия кнопки «OK».

Экспорт/импорт в XML и простой текст

При экспорте контейнера в XML (всех записей или их подмножества) также экспортируются все именованные политики, хранящиеся в данном контейнере. При импорте из XML-файла все именованные политики также импортируются в текущий контейнер. При этом, если в контейнере уже присутствует политика с таким же именем, и её настройки совпадают с импортируемыми, существующая одноимённая политика будет назначена соответствующим импортированным элементам. В случае, если именованная политика с совпадающим именем имеет другие параметры, к имени импортированной политики добавляется фраза «Импортировано дата/время» (где «дата/время» — дата и время импорта). Все соответствующие импортированные элементы будут привязаны к ней.

Все импортируемые записи, ссылающиеся на политику, отсутствующую в текущем контейнере или импортируемом XML-файле, будут привязаны к политике по умолчанию из текущего контейнера. Список затронутых элементов будет помещён в отчёт об импорте.

Имена связанных политик также экспортируются в простой текстовый файл. Но в настоящее время нет возможности сохранить в текст параметры именованных политик.

Поэтому, при импорте из текстового файла элементы, ссылающиеся на политики, отсутствующие в текущем контейнере, будут привязаны к политике по умолчанию. Список затронутых элементов будет помещён в отчёт об импорте.

Слияние и «перетаскивание» (Drag & Drop)

При слиянии двух контейнеров (целиком или частично) связанные с добавляемыми элементами именованные политики будут взяты из контейнера-источника. При этом, если в контейнере уже присутствует политика с таким же именем, и её настройки совпадают с импортируемыми, существующая одноимённая политика будет назначена соответствующим элементам. В случае, если именованная политика с совпадающим именем имеет другие параметры, к имени импортированной политики добавляется фраза «Объединено дата/время» (где «дата/время» — дата и время слияния). Все соответствующие элементы будут привязаны к ней.

Аналогично, при перетаскивании одного или нескольких элементов из одного контейнера в другой, для обеспечения уникальности будет использоваться фраза «Перетянуто дата/время».


Завершение работы мастера

Во время работы выбранной функции (сравнение, слияние, синхронизация или экспорт) на данной странице отображается используемый контейнер (сравнение, слияние, синхронизация) или файл, в который происходит запись (экспорт в простой текст или XML). Для отображения хода работы указывается текущий элемент (в виде «Группа» «Заголовок» «Имя пользователя»). Во время работы кнопки «Просмотр отчёта» и «Закончить» неактивны.

После завершения вы можете просмотреть отчёт и/или выйти из мастера. Из диалога просмотра вы можете сохранить данные на диск (файл будет сохранён в каталоге, содержащем текущий контейнер) и/или скопировать их в буфер обмена. После сохранения на диск отчёт становится доступен через пункт меню Просмотр→Отчёты. Обратите внимание, что при сохранении на диск происходит перезапись в каталоге контейнера предыдущего отчёта для выбранной функции. Примечание. Отчёт может содержать важные данные, поэтому возможность сохранения на диск следует использовать с осторожностью.


Мастер выбора файла или контейнера

Сравнение, слияние или синхронизация

При сравнении (слиянии, синхронизации) контейнеров требуется указать имя контейнера, который нужно сравнить (объединить, синхронизировать) с открытым в настоящий момент контейнером.

Запрашиваемый пароль относится к этому контейнеру, а не к уже открытому.

Экспорт в простой текст или XML

При экспорте текущего контейнера в простой текст или XML требуется указать имя файла, в который будут записаны данные (если указанный файл существует, будет выдан запрос подтверждения перезаписи).

Запрашиваемый пароль относится к открытому контейнеру.

Чтобы в последующем файл можно было корректно импортировать, нужно указать символ, используемый для разрыва строк в заметках. При экспорте в простой текст этот символ также используется для замены точек (.) в заголовке. Это сделано для того, чтобы при импорте можно было восстановить разбиение на группы, т. к. точка используется для отделения групп.

Расширенные условия отбора

Во всех случаях можно поставить флажок «Расширенные условия отбора». После этого будет доступна ещё одна страница, на которой можно указать ограничения по группе, заголовку, имени пользователя, ссылке или заметкам, а также отобрать поля для сравнения, слияния или экспорта.

Если вы передумаете, для экспорта всех элементов можно нажать кнопку «Назад» и снять флажок «Расширенные условия отбора».

Примечания:
  • Ограничения по группе, заголовку, имени пользователя, ссылке или заметкам недоступны, если через контекстное меню или меню «Изменить» экспортируется один элемент.
  • При слиянии контейнера с текущим невозможно указать, какие поля элемента будут скопированы. Если элемент попадает под условие отбора, он целиком помещается в текущий контейнер.